Resident Evil 7 not hooking (already searched threads)

Homepage Forums Technical Support Resident Evil 7 not hooking (already searched threads)

Viewing 15 posts - 1 through 15 (of 21 total)
  • Author
  • #185670

    Hi, like topic says, RE7 isn’t hooking. I’m on Win10, using a rift, on a 1080 card. When I run RE7.exe, a black window will pop up, the vorpx will say “attempting to attach to re7.exe” (or something along those lines), and then they (the black re7 screen and vorpx message) just disappear, as if nothing ever happened. After that, I checked processes just in case, which shows re7 isn’t running and vorpx is working as normal. So not only does it not hook, but it doesn’t seem to allow the game to run at all, crashing it to straight to desktop.

    I’ve done every bloody thing I can think of and still nothing, including:

    Reinstall both RE7 and vorpx.
    Rebooting into diagnostic startup.
    Making sure there are no non-essential processes or programs running.
    Disabling steam overlay.
    Disabling extra monitors and changing my 4k desktop resolution to 1080p.
    Running vorpx in admin (RE7 not admin).
    Using alternate hook mode in vorpx.
    Testing vorpx in other games (like Fallout 4, it works fine).
    A couple other things I’ve forgotten at the moment.

    I searched google and the forums here for similar problems and came across nothing relevant to my situation. I got RE7 specifically to use with VorpX, so it’s crushing me that it’s not working. Any help would be profoundly appreciated.


    Judging from your post you seem to have tried pretty much everything one could recommend. Since only RE7 is affected it’s probably something game specific, so the only two things left to suggest are:

    1. Try to run the game windowed if you run it fullscreen currently or vice versa.
    2. Make sure that you don’t use any mods (e.g. an FOV hack) that might interfere


    Is it possible some settings in the game would prevent attaching? Such as resolution, graphic settings, etc? If so, are there recommended settings?


    Nothing I can think of. Since the game is D3D11 only there isn’t any game setting that may have an effect on hooking.

    The only, very generic, thing left I could recommend is a factory reset in the vorpX config app. Reinstalling vorpX might not have reset everything to default unless you uninstalled it first, so a factory reset might be worth a shot.

    Also double and triple check running background processes. Everything that wouldn’t be there after a fresh Windows install is a candidate. Doubly true for potential third party AV programs, which aren’t necessary anymore on Windows 10.

    That’s really all I can suggest.


    Does the game crash even without vorpX?

    Also, it’s a good idea to launch a game just installed once without vorpX, so it can complete setup.

    Just skimmed the steam forums and there are lots of people with “crash on startup” problems. Fix propositions ranging from uninstalling certain windows media codecs, to defaulting the ini if you tweaked fov or resolution there, or checking your cpu is supported. Go have a look.

    Might have something to do with the intro video.

    I booted my re7 in vorpX just now to see, and it’s working as normal.

    Hope you can get it sorted. re7’s a pretty neat experience.


    Did all that you said Ralf, only essentials running, disabled defender and firewall, don’t even have a 3rd party antivirus program. Still no luck.

    Dellrifter22, I’ve actually already been playing RE7 a bit, have a couple hours into it, it’s work 100% without vorpx, never any crashes or glitches. I haven’t tweaked FOV or resolution, it’s all default game settings. The game ONLY crashes when running vorpx, after it says “attaching to re7”, a second later, the game window (which was only a black window in the first place) disappears.

    Seems I’m SOL in this case and have to play non-VR. Sucks, I was REALLY looking forward to this kickass game in VR, but no worries, still good without it, and I’m sure I’ll find some other games to use vorpx with eventually. Thanks for all the helps guys, very much appreciate you taking the time to troubleshoot with me.

    Kranky Pantz

    Not working with the Windows Store/ XBox “Play Anywhere” version.

    This is what I see when RE7 starts.
    Then It just plays as normal on my monitor, no vorpX.

    she dwelt among the untrodden ways meaning


    That’s exactly what happens to me. Well, there error message at least. I don’t get as far as the message that you got (“This game has an….”). Mine just shows a black box for about 5 seconds then shuts down. So you got a couple seconds longer than me, ha.

    Kranky Pantz

    Are you running the Steam version or the Microsoft Store version like I am???

    I am aware that there are issues with some games trying to hook to the Microsoft Store versions of games, but since this is a third party title it may be able to once the bugs are worked out.

    Fingers are crossed!


    The Microsoft Store probably is the curlprit here. Most (if not all) games from the Microsoft Store are protected against any kind of code injection.

    Kranky Pantz

    Does that also include playing games on a 2D screen in Immersive or Cinema mode, or just games that need to hook for a full VR experience?


    Did anyone have any success with this? Because I am stuck in the same boat, really wanted to try re7.
    Other games work fine this one crashes on startup, only with vorpx.


    The game is quite popular and not known to be probelematic in any way as far as hooking is concerned. Almost certainly a conflict with some other program on your PC.

    If you use anything else than Windows Defender your AV program the first and most likely candidate. Apart from that try to disable everything you may have running in the background, even if it doesn’t cause issues in other games. That’s the best way to trouble shoot a problem like this.

    As a last resort you can also try to check the ‘Alternative Hooking’ checkbox in the config app. Don’t forgot to uncheck it again later even if it helps. It’s not better, just different, and some games will definitely fail with it.


    Have the same problem. RE7 crash when Vorpx tries to attach.
    So bad there is no any solution here.
    ‘Alternative Hooking’ – not working
    Game without vorpx works with no problem.
    GPU 2070 RTX


    The game is quite popular and not known to be probelematic in any way as far as hooking is concerned. Almost certainly a conflict with some other program on your PC that also hooks into games.

    If you haven’t done so already, please check the trouble shooting post on top of this sub forum. It contains pretty much all relevant information in regard to hooking conflicts.

    Apart from that: the next vorpX version will come with a third hooking mechanism that should resolve most potential hooking conflicts except invasive AV programs by ensuring vorpX is always first.

Viewing 15 posts - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!