Sorry, we having trouble loading vorpControl.exe…

Homepage Forums Technical Support Sorry, we having trouble loading vorpControl.exe…

Viewing 15 posts - 1 through 15 (of 19 total)
  • Author
  • #100840

    I’m new to vorpX and am getting the following error in Oculus Home, when vorpX is started:

    Sorry, we’re having trouble loading vorpControl.exe. Please take off your headset and check your computer for error message. You may need to close vorpControl.exe or address windows associated with it in order to get back to VR.

    I’ve done numerous things:
    – Uninstalled vorpX, reboot, Installed vorpX
    – Ensured that vorpX was installed as Admin
    – Closed Oculus Home when installing
    – Installed in a new directory, and ensured the necessary software was closed before running the installer.
    – Latest Nvidia drivers installed.
    – Reboot after install of vorpX.

    Basically everything besides reinstalling Oculus software (Since I have roughly 20GB+ downloaded in games…I don’t want to have to redownload them again.

    Any insight or logs that I can provide?

    Windows 10 64-bit
    32GB RAM
    500GB Samsung SSD



    Does vorpX control still load and show its taskbar icon? If so, you probably should be able to simply close Oculus Home and everything else might work fine from there on.

    If vorpX does not show its taskbar icon, it probably crashed during start, whicht might result in what you see. In that case the first thing to do would be disabling background processes for trouble shooting, especially any additional virus scanner or security software you may have installed.


    I’m having the same problem. I’m using my DK2 with 1.3 installed. Whenever I start an app using VorpX, I get the standard Please Wait screen displayed with any VRT app and is just says “Sorry, we’re having trouble loading xxx.exe. Please take off your headset and check your computer for error message. You may need to close vorpControl.exe or address windows associated with it in order to get back to VR.” were xxx.exe is whatever is trying to use VorpX. Sometimes it’s the control panel. Other time is WoW-64. Basically something is not working.


    Please check for the things mentioned in my post above yours.


    Done that. First thing I did.

    And the icon is sitting in my tray so it hasn’t crashed.


    Then you will probably by able solve this by closing Oculus Home and restarting a game should this happen while starting a game.

    If it always happens when starting a particular game, please check whether that particular game may have crashed on start. If that is case, there might be an injection conflict. In that case, please check the trouble shooting guide regard to conflicts.


    Try switching between DX9 and DX11 in WOW and between 32/64bit. if one is not working for you, the other might.


    I’ve noticed that EVERY time I start a VR app (or start an app that uses VorpX) it starts Oculus Home. Even if I close Home, as soon as I start app used by VorpX, Home start right up again. Is that the problem?


    That is how things work since runtime 1.3. No way around that.


    Ok …. I tried Fallout 4. It started in VorpX, but crashed before fully loading (but I think that was savegame related). Perhaps it’s an issue with WoW. I’ll look into a bit more.


    Just to update this. I put on Oculus Home, made sure the game has the .exe tracked in the VorpX app, and once launching the game, it loads in the CV1. Sometimes takes a few tries, but have gotten 3 games to load so far. Thanks for the help!


    I can not get VorpX to load anything. I was just get a black screen. Fully updated drivers, VorpX is latest version. Not sure what else to try…. I just purchased VorpX wanting to use it for Witcher 3 and Fallout 4.

    Now I see Oculus Home… when i launch a game, I get the screen for loading, then the game launches on my desktop and Vorpx just crashes. When I mouse over the VorpX icon it disappears.


    That sounds like a potential conflict with some other software on your PC that also hooks into games. Most likely candidates are: virus scanners, CPU/GPU utilities, video capture/streaming programs, chat programs and generally everything that can display notifications in games.

    To trouble shoot such an issue please try to disable/uninstall everything that would not run on a fresh Windows install. Additional information can be found in the trouble shooting guide in the vorpX help.


    Hi Ralf,

    I’ve been having the same problem as the guys above, I haven’t fixed the problem yet however the nature of the beast has changed which will hopefully lead to a solution. Before this turns into a thesis I’d like to state that Oculus Apps, 3rd party apps (whirlwig etc), vorpx desktop viewer and video player (VLC) are working fine.

    I’m running the following:
    Windows 10 Pro 64 bit
    Nvidia driver 364.72 – latest non beta.
    Oculus runtime 1.3
    Vorpx 16.1.2
    Avast Antivirus
    I don’t run any other apps that hook into the games and I have ensured that Nvidia shadowplay is disabled.

    Initially I was receiving the “Sorry, we’re having trouble loading vorpControl.exe.” error message however VorpX Control was still running, upon trying to launch supported titles from steam, Uplay I would receive “Sorry, we’re having trouble loading xxx.exe”.
    – VorpX was running as administrator
    – Tried disabling antivirus temporarily
    – Tried Far Cry 3 + 4 and GTA V

    I completely removed VorpX and the Oculus software from my workstation, restarted and reinstalled both of them with antivirus temporarily disabled. The Vorpx behaviour was more or less the same however the game hooking was completely broken this time around (no more Sorry, we’re having trouble loading xxx.exe). Launching games via steam/uplay would result in generic error messages or time outs if Vorpx was running (installed and running with administrator rights). If I attempted to launch the game exe’s directly I would receive access denied error messages, pausing the Vorpx watcher would result in the game launching normally.

    I’ve been looking through some procmon logs for clues, unfortunately I don’t have a sound understanding of what’s going on here but I noted the following:

    VorpXControl.exe failed to create these files immediately.
    C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Far Cry 3\bin\d3d9.dll
    C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Far Cry 3\bin\dxgi.dll
    C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Far Cry 3\bin\d3d11.dll
    C:\Program Files (x86)\Ubisoft\Ubisoft Game Launcher\games\Far Cry 3\bin\d3d10.dll

    The farycry3.exe, vorpxcontrol.exe and OculusVR.exe continue after this point. Logs end abrubtly after the initialisation of audio drivers, haven’t been able to narrow down the culprit yet. I suspect it’s Avast antivirus as it’s still got it’s finger in the pie in procmon when its supposed be disabled…

    I have found that killing off Avast antivirus has resulted in games working (still takes 2-3 attempts).


    I also got the in-VR error message “Sorry, we’re having trouble loading vorpControl.exe” etc. No error message in windows ofc.

    However, if I just close that Oculus home VR/store-thing, and leave vorpControl.exe *32 and vorpControl64.dat running (task manager), and then start a game, in my case I’ve only tried Fallout 4 so far, it seems to work. Poorly though. In all 3D modes, and especially 3D geometry.

    I did run the Game settings optimizer from VorpX Config btw, for Fallout 4. The VR visuals is pretty good in geometry mode, just saying. But performance is just useless. Too bad really.
    I don’t know what exactly the FPS is, as EVGA precision (v. 3.0.1) can’t display the FPS counter in FO4. I guess it’s 10-15-ish, give or take. Usually (non-VR) it’s butter smooth.

    Using Oculus Rift DK2, latest runtime 1.3 ( as reported by Bilago’s VR manager, since I couldn’t figure out where I find this info from Oculus home).

    And Windows 7 ultimate 64-bit, GTX 970 with nVidia driver 364.72.

    Also, that Oculus home thing starts when I quit vorpX. Also when I start vorpX, but then that error message pops up after a while.

    Now I won’t rule out that I’ve managed to mess something up while installing a runtime switcher, since I discovered that runtime 0.7 somehow didn’t get installed properly (missed the OculusConfigUtil.exe), so I had to reinstall that, twice, and then reinstall the newest 1.3.something. But it seems to work now. Except with the vorpX performance being very bad.

Viewing 15 posts - 1 through 15 (of 19 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!