various difficulties

Homepage Forums Technical Support various difficulties

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #197420

    Lots of problems

    I’m having a hard time getting VorpX to work.

    – some games don’t hook, even why I try with a helper, even officially supported games, f.e. Metro Exodus.

    – when a game hooks and I try Full VR, f.e. Outlast 1, the graphics look very bad with a lot of noise? (Maybe because that game is old?)

    – if the game hooks, and visuals are good, then I always have another problem no matter which mode (full VR or immersive screen) : my Xbox controller doesn’t work at all, or works with a wrong layout.
    VorpX is by default using my Quest 2 controllers as “KB/mouse”. I have to remove the battery from the controllers to get the Xbox gamepad to work. But the gamepad is then used as “KB/mouse” and the game thinks I’m using KB/mouse (while playing I see “now press F to do action blabla”). And some gamepad buttons don’t even work or some actions can’t be done with the gamepad (although with the normal gamepad layout, it’s possible).
    If I change controller settings in the in-game VorpX menu to “gamepad”, the gamepad isn’t doing anything. And when I set controllers to “Off”, again nothing. Only “KB/mouse” makes the gamepad work (but like I mentioned already : only with a wrong gamepad layout and not every button works).

    – one last thing : when G3D / geometry isn’t available, it doesn’t matter whether I choose Z-normal or Z-adaptive or Off: in all three cases I have zero 3D effect whatsoever. I tried this with several games. Only Geometry provides a 3D effect, the other not even a little bit. It’s not about missing a subtle change, I tested and tested again and again and could only see flat, 2D graphics. I’ve played with FOV, zoom, the 3D depth slider, etc, etc, always flat?!
    There also was one game: Bright Memory which should support Geometry but when I enabled it, the right eye could only see the HUD on a black background. Z-adaptive and normal gave flat graphics again and controller didn’t work well as usual. :)

    I hate to say this but I haven’t been able to make it work well with even one, single game. :(

    I’m using the latest v20.x version (downloaded very recently).


    First off, check some games from this list. Good choices while you are new to vorpX:

    Good Full VR Games for Beginners

    Also make sure to check the ‘Essential Hints Guide’ in the help, which explains a few basic concepts and helps avoiding a lot of unnecessary trial and error with games that aren’t as automated as the ones in the list above.


    If you encounter hooking issues with multiple games, there almost certainly is some conflict with another program on your PC that also hooks into games. The most likely candidate would be some invasive third party AV program you might have installed, but there are a bunch of others. More programs than one would think hook into games. The pinned trouble shooting guide on top of this sub-forum has more details on the matter.

    Graphics Fidelity:

    Outlast in particular has some noise filter applied to the image IIRC. You might be able to turn that off in the game options. Apart from that: for better image quality it’s useful to raise a game’s resolution. Typically 1440p looks fairly good. If performance allows, you can go even higher. You have to see from game to game what your PC can handle. In some games you can choose a preferred quality in the vorpX menu. You see a message in the top left corner of the game window whenever that is the case. Check the ‘Custom Resolutions’ section in the help to get the most out of this feature.


    Some games (quite a lot actually) don’t allow mouse and gamepad input at the same time. Whenever vorpX has to emulate a mouse for headtracking, you normally wouldn’t be able to use a gamepad at all in such a game. To deal with the matter vorpX comes with a built in gamepad > mouse/kb mapper that is usually activated in games that are known to not allow mouse and gamepad at the same time. You can freely configure the mapping to your liking on the input page of the vorpX menu (or play with mouse/kb of course).

    Another option would be to use your VR controllers, for which vorpX povides similar mapping capabilites, with the added benefit of an ingame overlay on the rendered controllers that always shows the current mapping. so that’s more intuitive to use than an actual gamepad.

    You could also configure vorpX to handle it the other way around and emulate a gamepad with head tracking in affected games, but that’s generally not recommended since rather laggy due to the heavy filtering games apply to gamepad input usually.


    When you start unsupported games with vorpX, it tries to automatically figure out a depth buffer for Z3D, but there is no guarantee that it actually finds a valid one, more often than not it probably won’t without some guidance. Only games with profiles are guaranteed to have 3D, be it Z3D or G3D.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!