vorpX config error, please help!

Homepage Forums Technical Support vorpX config error, please help!

Viewing 15 posts - 1 through 15 (of 28 total)
  • Author
  • #21139

    I picked up my dk2 yesterday and thought I would give vorpX a try, but I can’t run the configuration utility. “I always get vorpX Config encountered an unspecified error and has to exit”. I am using the new 0.4.3 runtime, but I think the error is elsewhere.


    The 0.43 runtime indeed almost certainly isn’t the problem. Please rename/delete the following folder: C:\Users\[Username]\AppData\Local\Oculus. This might solve the issue.

    The AppData directory may be hidden, you have to enable ‘Show hidden files’ in Windows Explorer to see it.

    if that doesn’t help, please try to uninstall/reinstall vorpX in case you haven’t done that already. You can keep the registry information when being asked while uninstalling.

    The config app isn’t that important currently BTW. Almost all settings can be changed in-game through the vorpX in-game menu (press [DEL] to open it).


    Yeah the in-game menu works fine, I didn’t know the config part didn’t do a whole lot. I’m going to reformat soon so maybe that will fix it.


    I have the same exact issue, Just received my DK2, paid for vorpx, other games and demos work but when launching vorpx I get the error “vorpX Config encountered an unspecified error and has to exit”

    Everything is up to date, firmware sdk runtime etc.


    Same problem here. Also the web installer for vorp always downloads and installs the obsolete 0.4.1 oculus runtime. So after installing vorp I’m forced to uninstall the obsolete drivers and install the latest ones, or I get a hardlock and system restart the second I turn on the dk2.

    After installing vorp, uninstalling the old runtime, reinstalling the latest runtime, I get the fatal error when trying to launch vorp config but Skyrim starts up…on the wrong screen-always.

    If I disable or disconnect my main monitor and simply launch the game with just the rift connected as main display, I get half a screen. I also tried VR game launcher with skyrim set to rift as main display, same thing, half a screen on the rift. If I set the rift to direct hdm access and launch I simply get an error message and vorp crashes.

    Well, $50 well spent I suppose.


    Please make sure to set the Rift as PRIMARY monitor in the Windows monitor configuration. This will solve your issue with games opening in the wrong display.

    If you want to use the Rift as secondary monitor you have the set vorpX to “Show on Rift DK2” in the config app, for which you need the config app, of course.

    This is explained in greater detail (including screenshots) in the DK2 Setup Guide that comes with vorpX.

    The config app crash may be related to a faulty DotNet installation on your machine. You can check that with the DotNet repair tool from the Microsoft website:


    Please also try to diable your virus scanner temporarily. it might cause a conflict with vorpX.


    I have the same problem. I can’t get to the VorpX config. I’ve done overything you said and it’s still the same. It won’t even work with any game. Most of the time the game launches and the display is all messed up, sometimes the eyes are swapped and It sometimes ignores my settings by changing my resolution to 948×1080. Nothing has worked at all and everything is unplayable. I would really appreciate some help, I havent used this oculus rift on a single game since I got it. It’s just on error piled on another


    Also, ever since i reinstalled vorpX everything has gotten worse. Now, unless i have my oculus rift as the main display, vorpX won’t start at all. It just says it can’t find the device, even though its clearly on. So running vorpx means looking through onle of the lenses with one eye shut to see half a screen and try to navigate my desktop with that. And it never runs anything on the display anyway. I’m sorry if i sound rude, I’m just extremely frustrated. I spent quite a bit of money on my oclus rift + vorpx to be able to play more games on it and nothing is working. It feels like an expensive brick.


    The only correct resolution for using vorpX with the DK2 is 1920×1080. Other resolutions probably lead to games being displayed wrong one way or the other,

    Please also make sure to set the Rift to “Portrait” mode in the Windows display config (Win7), or maybe “Landscape flipped” (Win8).

    With this setup vorpX will work just fine whwn using the DK2 as primary display. This is actually the most compatible option.

    In regard to the config app crash temporarily disabling or uninstalling your virus scanner may be worth a try.

    If that doesn’t help, you can use vorpX with the above setup. Most things that can be done in the config app can also be adjusted ingame after pressing [DEL].


    I’ve tried everything you said so far and nothing. I don’t use a virus scanner. I’ve installed everything the way you’ve recommended. Lately vorpx won’t even use the display. it just runs games on the monitor ignoring the oculus entirely or not run it all. If I move the games window over to the oculus and make it full screen the image is distorted as if it were meant to be displayed on a monitor. It also shows the vorpx pop up window like it would if it was working.


    Please set everything up as shown below. Do not leave out anything. When you follow all five steps, every game will open on the DK2 automatically, even without the config app.

    1. Reinstall vorpX to reset everything to default
    2. Set the Rift to Extend Desktop mode with the Oculus Config Tool
    3. Make the the DK2 the PRIMARY display in Windows
    4. Set the orientation of the DK2 to “Portrait” or in Win8 possibly “Landscape flipped”
    5. Run all games at 1920×1080 in fullscreen mode, not windowed.

    Yoy should also make sure to set the FOV to 120. Depending on the game from best to worst here is what you can do in this regard:

    1. Set the game FOV directly in the game if it provides to dial in an FOV of 120°,
    2. Set the game FOV directly with the vorpX Game Optimizer (vorpX config app) for games that support it.
    3. Set the game FOV to 120 manually through an ini tweak or external tool (avaliable for many games, google FOV + game name).
    4. Use the 3D FOV Enhancement in the vorpX ingame menu (availabe in Geometry 3D games).
    5. Use one of the letterbox aspect ratio modes in the vorpX ingame menu and/or ImageZoom
    6. Use the 2D FOV-Enhancement in the vopX ingame menu (be aware that this distorts the image)


    I’ve actually followed those steps. The reason I mentioned windowed is cause The game would not display so id have to alt+tab until i get to the right window and then use windows button+arrow until it was on the montitor then force it back over tot eh dk2 and use alt+enter to fullscreen it. and the screen would be a wacky then


    I’m having some similar, although possibly unrelated problems with my install of Vorpx.

    I installed it and it all seemed to run ok, albeit the view in the rift was sideways, but when I started a game (Skyrim) it put my monitor into 1024×768 resoolution, and crashed the game. Sorry can’t recall the exact error message now. Not only that, but afterwards, any time I turned on the DK2, my monitor and DK2 would reset to the 1024×768 resolution, and there was no way to return it to 1920×1080. None of the higher resolutions even appeared in my nvidia control panel.

    Frustrated after an hour or so trying to fix it, I uninstalled Vorpx, but the resolution would still go low whenever I turned on my DK2. I ended up having to roll back to an earlier restore point just to get things functioning again. Needless to say I’m hesitant to reinstall it now, but I would really like to get it working since it wasn’t exactly cheap.

    I suspect part of the problem may have been that I fiddled with some of the config tool settings before even trying it in a game. Reading some of the threads here, that may have been a mistake.

    I’m running Windows 7 64 bit and the 1.4.3 runtime for the DK2. Please help.


    Never heard of anything like this before, so it might just have been a coincidence. You should run every game at 1920×1080 with vorpX.

    Please also check the DK2 setup guide in the vorpX documentation in case you haven’t done so already. It explains the two possible display configurations that you can use vorpX with. In short:

    A. The convenient one (does not work with everything)

    1. Set the Rift DK2 to “Extend Desktop to HMD”
    2. Use the Rift DK2 as SECONDARY monitor in Windows
    3. Set vorpX to “Show only on DK2? display wise in the vorpX config app

    B. The compatible one

    1. Set the Rift DK2 to “Extend Desktop to HMD”
    2. Use the Rift DK2 as PRIMARY monitor in Windows
    3. Set vorpX to “Use system settings” display wise in the vorpX config app

    In both cases you have to change the orientation of the DK2. Usually to “Portait”, in Windows 8 in some cases to “Landscape flipped”


    Well, after about 8th reinstallation, everything seems to be in order. Not sure what the problem was or what solved it. Thanks for the help, Ralf.

Viewing 15 posts - 1 through 15 (of 28 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!