Vorpx Hooking to Skyrim through Mod Organizer

Homepage Forums Technical Support Vorpx Hooking to Skyrim through Mod Organizer

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
  • #128059

    Hello Everyone,

    I know there are a few posts out there around Mod Organiser and from what limited info there is its not very promising on getting it to work with VORPX easily. Curious to see if anyone has been successful in using Mod Organiser and getting it to hook when you Launch SKSE.

    Personally I get a failure message if I run both programs in admin (Launching “\steamapps\common\Skyrim\\TESV.exe” failed (5).) If I dont run with admin mod the game runs but doesnt hook at all.

    Curious to see if anyone else has had any luck and if so any tips on how I can get it to hook properly!

    I know NMM works and I am using that currently as a result. However, my personal preference would be to use MO vs NMM if there is a solution on how to get it to hook properly.

    Until then I’ll Skyrim in VR Through NMM :)

    One day I’ll figure out how to get the ENB Injector version and VORPX to work properly but first MO!

    Thanks Ralf for all the hard work. Vorpx has been a great way to experience VR and worth every penny!

    Thanks also to any who can give me tips on how to get MO to work also :)



    I run both MO and VorpX as Administrator. And it works fine.
    You get an error about TESV.exe, but where do you get it? I mean – in MO you launch SKSE and this is what VorpX is supposed to hook up to. That’s why is strange that you get an error about TESV.exe – the vanilla executable.


    Thanks for responding Prinyo!

    I get the error when I try to Run skyrim via MO through SKSE. Both Vorpx and MO in admin mode.

    I’ll continue to goof around with it while I play in VR via NMM but i know modding is just not as easy in the way I like to do it without MO.

    If you have any ideas on what I can try let me know!




    Two more things to check.

    Are you running SKSE as admin (skse_loader.exe). I run TESV.exe also as admin, but not sure if it is necessary.

    Did you fill the “Start in” in MO in the link to start SKSE.
    In my case :
    Binary: E:\steam\steamapps\common\Skyrim\skse_loader.exe
    Start in: E:\steam\steamapps\common\Skyrim


    Hey Prinyo,

    Yep I have SKSE and TESV.exe defaulted to run admin mode. I have tried with both on and off.. though it wont work without SKSE in admin mode.

    SKSE is set wit the following for me
    Binary: D:\Steam Games\steamapps\common\Skyrim\skse_loader.exe
    Start in: D:\Steam Games\steamapps\common\Skyrim

    Any other ideas by chance?




    I didn’t do anything special and it works for me, except that the first time I start Skyrim, it comes up on the monitor instead of VR: I get the ‘TESV.exe is taking a while to start’ message, but VorpX never switches to VR.

    The second time, it usually comes up with no problems.

    I also run with the ENB Injector, but all ENB graphics options disabled, to get the ENB memory manager to prevent mod crashes.


    Hm – whatever I do:
    running MO as admin, running vorpX as admin – vorpX wont hook.
    Only if I start skse_loader outside of MO – but then I have no mods.

    But vorpX Control throws the error “Injection failed: Unable to hook: nxmhandler.exe”


    Which version of MO is supported?
    There is the last official 1.3.11 and a 64bit v2.07 Beta 3
    I have no success with 1.3.11


    But vorpX Control throws the error “Injection failed: Unable to hook: nxmhandler.exe”

    This is fine. It happens if you start MO after VorpX.

    It seems to me there is difference between the Rift and the Vive in the setup for VorpX and MO. I’m using Vive and for me it always works :

    – Start MO
    – Start VorpX
    – Start the ENB injector (for the ENB Boost) via MO
    – Start SKSE via MO

    Seems this doesn’t work for the Rift. Hope somebody who knows how to make it work explains the steps.


    @ zian: vorpX is not supposed to hook into nxmhandler.exe. To avoid that message please add nxmhandler.exe to your exclude list in the vorpX config app.


    Even if the warning message has gone now – vorpx is still not able to hook SKSE loader
    (MO 1.3.11, Oculus Rift Client 1.5)
    Tried MO 64bit too
    Only NMM works.


    Hi today i gave MO another try because NMM cause my modded game to crash almost every minute. Here is what i did.
    The problem is when starting tesv through MO with skse the well known message .. exe or waiting too long appears. The reason is that one needs to pause the vorpx watcher first and than start skse in mo and then resume vorpx watcher . The problem here is, that when starting skse skyrim loads immediately so that one has not time to resume the vorpx watcher it just too fast game start. So I used the enb injector . I first run the enb injector, than pause voprx watcher, than start skse in MO and as fast as possible i resume the vorpx watcher. that did the trick so the enb injector somehow delays the start of tesv.exe.
    If someone knows how to delay the tesv.exe through MO that would be more convenient since to get the coursor to the vorpy resume is bit tricky atleast for me..
    But anyways MO and 230 mods running as for the ctds i will see tomorrow…..


    … one needs to pause the vorpx watcher first and than start skse in mo and then resume vorpx watcher…

    Hmm, try to add skse_loader.exe to the ignore list of VorpX. From what you describe it seems this will be the solution. I’m only guessing here, but it seems the SKSE loader breaks/confuses the attempt of VorpX to intercept the game.

    It would help if everybody specifies if they use Rift or Vive when posting. I have the feeling this is something specific to the Rift’s software.


    Hi, its a rift
    and all related programs are on the vorpx ignore list.
    As said F4SE ond other scriptextenders run well and NMM with skse works prefect, the problem is that if u use MO and skse tes5.exe starts immediately, whereas starting through NMM its a delay of two or three seconds that helps to resume the previously pause vorpx watcher…. The problem is MO related….


    The problem is MO related….

    Not exactly, since it works as intended with a Vive. There is something Rift specific that breaks it, it seems.
    Why do you need to pause the watcher? This means there is something that is breaking the attempt of VorpX to hook into the game. You don’t need to do that with a Vive.
    I guess there is something in the Oculus’ environment that is confusing VorpX when SKSE is started via MO.

    Can you run any ENB?

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!