Weird stutter issue in Skyrim all of a sudden

Homepage Forums Technical Support Weird stutter issue in Skyrim all of a sudden

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #104954


    I’ve been playing Skyrim with VorpX a lot and really enjoyed it. My combination of mods, Skyrim settings and VorpX settings has been working pretty well, until now.

    After about a 2 weeks long break, I find that the game stutters anywhere – Even small places with great framerate, and places that have been smooth as butter before. The stuttering is hard to describe – It doesn’t feel like bad framerate, but it seems like the image “lags” behind or jumps around somewhat now and then, and sometimes it feels like I’m seeing double for a split second.

    The weird part, which I hope might help solve the problem, is that this issue is completely gone while the VorpX menu is showing on top. As soon as I bring that up, everything is as it was before. But I’d rather not play with that in the middle of my vision :)

    The only system change I can think of that has been made since I last played is an Nvidia driver update, and I have tried rolling back the driver to one I know worked well, without luck.

    Does anyone have any thoughts on what might be the reason?

    Edit: I can add that I’m using the Rift CV1 and that I’ve tested some native VR games after I discovered this issue, which worked perfectly.


    Here’s an update, after fiddling a bit today:

    I just found out that lowering my resolution makes the problem disappear. I previously used 1280×1024 for Skyrim, and changing it to 1280×720 fixed it. It does not seem to be related to aspect ratio, as the problem reappears if I go with 1600×900, and vanishes again if I use 600×480.

    This is not ideal, since 1280×1024 was pretty much the sweet spot between quality and performance and made menus both legible and compact enough, but at least I can play! \o/

    I would still like to get to the bottom of the issue, though. Really curious why the problem would disappear regardless of resolution when the VorpX menu is active.


    That sounds really odd. I tried to recreate this when I first read about it, but couldn’t for the life of me. With settings that don’t allow a stutter free image there is no difference here with or without the menu open. So, I’m officially stumped here, sorry.

    I’ll try again with different aspect ratios, but I can’t really imagine how that could cause such an issue.


    Yeah, it’s super weird. The only visible change with the menu open is that the VorpX mouse cursor appears, but I tried ALT+C to bring the cursor up while the menu was closed, and that didn’t help.

    I have tried a couple more resolutions now, and each I’ve tried below 1280×1024 works fine, regardless of aspect ratio. I’m currently playing with 900×720. It does have the benefit of actually keeping close to 90 fps in some interiors :D

    On the higher resolutions the issue appears somewhere between 60 to 70 fps and above – I’ve gone to locations where the framerate would stay around those numbers while on a “good” low resolution, and the issue is still gone.

    I’ll let you know if I make any other discoveries.

    Edit: Just so you know, I can add that I previously tried running Skyrim unmodified with stock VorpX settings (using 1280×1024), and the image would still get jittery somewhere above 60 fps, so it doesn’t seem to be directly caused by either.


    I can confirm the ‘same’ issue.
    I built a new machine and skyrim (Original version) was running wonderfully under vorpx for a few days of play. The next day i have Head Tracking stutter and it won’t go away. No new drivers installed (although i can’t account for what Windows 10 does under the hood.) The other game i’ve played in Vorpx So far (GTAV) did not experience the issue. When the headtrack is disabled in skyrim itself but on inside the 3d lounge room it’s smooth as expected … It’s something to do with mouse input + skyrim + vorpx. I did install a 3d Vision mod but it’s been disabled – it’s the only mod I applied and was disabled before beginning vorpx play.

    As the OP mentioned the issue is gone at resolutions under 1024×768.

    I’ve changed the bMouseAcceleration=0 in skyrimprefs.

    Mouse: logitech g600 (the issue remained after unplugging the mouse in-game)
    6 core i7
    windows 10
    16gb ram
    geforce 1070


    Fix Found (For Me) : Under In-Game VorpX > Display Settings >
    Turn ‘Direct Mode Async Render’ to Off

    Testing notes: while trying to figure out the issue I noticed the farther away from the ideal FOV the more the stuttering diminished. (It was gone at Fov 50 and Fov 200)

    Time to get back to into Skyrim.


    With the latest Oculus Software 1.10 Oculus introduced a new feature called “Asynchronous Spacewarp” which is always enabled and meant to enhance the experience with frame rates below 90fps.

    There can be situations where Asynchronous Spacewarp introduces quite heavy judder (more precise: randomly inserted wrong frames a few times per second) with the current vorpX version. If you experience this, please enable “Fluid Sync” on the display page of the vorpX ingame menu. Doing that reliably fixes the issue.

    The conditions that can lead to this are already known, a hotfix that addresses it without you having to enable Fluid Sync will be made available next week.


    Thank you for the explanation- that’s definitely better than my original fix!


    The hotfix that addresses the Asynchronous Spacewarp glitch is now available.

    Read more about it here.


    is this still an issue?? seems as soon as I use the direct vr option that’s when the studdering issue comes back.. and its only when I move the mouse when I move the head it is smooth.


    actually did more test looks like its more my mouse problem than the program maybe never noticed it before.
    vr did make it look worst

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!