WMR Headsets Require SteamVR Runtime?

Homepage Forums General vorpX Discussion WMR Headsets Require SteamVR Runtime?

Viewing 10 posts - 16 through 25 (of 25 total)
  • Author
  • #207849

    First start the mixed-reality-portal, without it nothing will work with the Headset, then start vorpx (not the vorpx desktop viewer) and at last the game via steam, uplay etc or *.exe. The Steam VR Mode, SteamVR and SteamVR-For-Mixed-Reality Apps have to be closed. Vorpx will detect every *.exe linked in a vorpx game profile und start it in VR.


    @ DaveSt: You ONLY need SteamVR for WMR headsets when you are using vorpX in SteamVR mode. WMR has native OpenXR support, so when WMR is set as your OpenXR runtime and you have selected OpenXR in the vorpX config app, there is no need to run SteamVR at all.

    This confusion is pretty much Valve’s fault, since they try to force SteamVR as OpenXR runtime even for headsets with native OpenXR. Just speculation, but if I had to guess, I’d say that probably was a business decision, so that everyone always gets to see the Steam store in their headset. Somewhat understandable to a degree from their perspective, but annoying as hell for sure.


    Sorry Ralf but i got no luck with OpenXR, after reinstalling the WMR Portal 5 times vorpX will simply not work even with no SteamVR installed. I did got the OpenXR demo scene to work again so i know OpenXR is working, just not with vorpX; unfortunately there doesn’t seem to be any game or app that uses OpenXR (other than Minecraft) so i couldn’t test it longer.

    I had thought it used to work but from this experience i know it actually didn’t as i had been using SteamVR all along. Not sure what could be the problem as i’m completely up to date, only thing i didn’t try was reinstalling vorpX but i’d rather not lose my configurations


    try to make a full factory reset of vorpx, and make sure that your Headset shows the WMR Cliff House before you start a game !


    you can make a quick test of openxr with reshade vr companion app. If you will have similar problems with that tool, you should contact the wmr customer service of your Headset.


    No luck running it and for some reason even the demo stopped working. All i could find was this support thread:


    That’s my situation, from the responses it seems there’s still a few bugs to work out as they couldn’t find the cause, atm it’s not that big of a problem so hopefully they’ll fix it in the next couple updates


    What happens after you start the vr companion app in openxr mode ? Nothing ?


    It tries to load (similar screen transition as with SteamVR but with the OpenXR logo) but then it hangs/crashes with a visible black screen flicker and the WMR Portal restarts again. Then in the WMR OpenXR dev tool the “system status” tab changes from displaying all the information, configuration and extensions to this:

    Exception XrResult failure [XR_ERROR_LIMIT_REACHED]
    Origin: xrCreateInstance(&createInfo, instance.Put())

    Same thing happens when i try to run the dev tool demo, it’s a generic error so no idea what causes it and from the link the devs found nothing from logs so hard to say what could be the problem atm. The person having the same problem started with an Acer H101 (same hmd as mine) but then tried a Reverb G2 with same results so it’s definitely not my hmd.

    In contrast, when trying vorpX nothing happens in the hmd, the dev tool doesn’t changes either and vorpX just gives the “severe error” warning, then the window opens with the vorpX logo as normal but the hmd never registers anything and stays in the Cliffhouse.


    I have the same issue when i try to launch ESO with openXR: “OpenXR session init failed”. I tried to reinstall mixed reality portal many times and i still have this error.
    I was able to launch it with openXR a few months ago. Now the only way to launch the game is switching Vorpx to SteamVR.
    Someone found a way to fix this?


    I gotta bump this thread because i’ve ordered a HP Reverb G2. I would like to ask:

    1) Is this issue still present or has it been fixed?

    2) Does SteamVR work worse in terms of performance? By how much?

Viewing 10 posts - 16 through 25 (of 25 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!