Cyberpunk crashing on load

Homepage Forums Technical Support Cyberpunk crashing on load

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
  • #209666

    Hi Ralf,

    First, huge thanks for the new CP2077 stuff. I’ve been using Vorpx for a while in Immersive Screen mode and super excited about your new release.

    On a 3080 with a Ryzen 9 5900X 12-Core. Using Reverb G2 with OpenXR.

    Installed it, ramped my game settings down to default Medium. When I start the game, during the loading screen, the FPS drops to 1 and the game stutters and crashes.

    Things I tried:
    Made sure I didn’t have SteamVR running
    Dropped down to Z-Render
    Dropped down to default Low
    Switched from Full VR to Immersive Screen

    No matter how low I drive this thing, it deeps stalling, dropping FPS to nothing, and crashing. Any ideas?

    Thanks in advance


    Please redownload the latest version of the mod, then uninstall the one you have currently installed and reinstall the latest version. Your rig is almost identical to my main dev machine, incidentally I even have the Reverb G2 connected currently. So everything should work fine normally.

    If you happen to have other mods installed, please remove them and try with only the VR mod installed.

    Just in case: make sure that Windows Mixed Reality is your OpenXR runtime. Unfortunately SteamVR also tries to make itself the system’s OpenXR runtime, but that is not what you want with a WMR headset. SteamVR should not run at all.


    Thanks so much Ralf.

    I’ve Googled this: “Just in case: make sure that Windows Mixed Reality is your OpenXR runtime.”

    Found these instructions:

    Change to WMR OpenXR runtime:

    Download from WindowsStore “OpenXR Developer Tools for Windows Mixed Reality”.
    Connect your WMR headset (Reverb G2 in my case).
    Launch Mixed Reality Portal.
    Launch “OpenXR Developer Tools for Windows Mixed Reality”.
    Go to Home (default) tab in “OpenXR Developer Tools for Windows Mixed Reality”.
    Press “Set as active runtime” button.

    Problem is…….I don’t see any “set as active runtime” button. Will search these forums for steps, but if I’m missing something, please lmk. Thanks!!


    PS – I made sure that OpenXR was the only thing running, no Steam.

    Uninstalled, reinstalled, tried again. Didn’t totally crash, but dropped to 7-13 FPS, headset like 1-3 and was a mess.

    I’ve never modded or have anything else running. Hm. Any other ideas?


    With your rig you should be able to easily get largely stable 60FPS, BUT: you can’t run the game with all graphics details cranked up to ultra. For a 3080 medium with high texture details should work fine.

    The best way to find your personal sweetspot is going the route suggested by the ingame instructions: start with graphics details set to “Low” in the game options, then raise the details and/or the resolution to find the compromise between graphics fidelity and performance that works best for you.

    What I personally do with a 3080 is this:


    Graphics details medium and ‘Resolution Quality’ in the vorpX menu at ‘Nicer’.


    Graphics details medium + DLSS at ‘Auto’ and ‘Resolution Quality’ in the vorpX menu at ‘Phenomenal’.


    Thanks Ralf.

    I’m stumped. I put my setting down to Medium and Resolution Quality to Nice, and as soon as the game loads, it drops down to 14 FPS.

    even though I don’t see SteamVR running I can’t help but wonder if I haven’t figured out the OpenXR runtime thing. Going to look that up.


    Definitely something weird going on. Even with SteamVR you should see much better performance, it’s “just” a bit juddery with WMR headsets, hence OpenXR is the better choice for WMR.

    Just in case: if you happen to have any mods installed, try without. Also if you have any tools or utilities running that potentially hook into games, try to disable them.

    BTW: The developer tools aren’t required anymore these days. The WMR portal app will complain at launch if WMR is not set as OpenXR runtime. if the WMR portal doesn’t complain, OpenXR should be set up correctly.


    I don’t have any mods or tools that I know of. I’m going to do a backup/reinstall of Cyberpunk, then Windows if I have to, then report back. Thanks.


    Hey Ralf,

    I reinstalled Windows, CP2077, and today’s update. I think I might know what was happening – I don’t think my graphics adjustment were “taking” for some reason last time.

    Unfortunately, now when I try to load the game, I get this: ‘Unable to load vpxCP2077.asi. Error 126.

    Any ideas? Already uninstalled, redownloaded, and reinstalled your mod.


    Ok, figured that out. I had never installed SteamVR at all, so I just ran that. Made sure OpenXR was still my runtime tho.

    So now I’m able to load into the game, but weirdly, the screen moves with my head now. So close…


    Dang. Ok. This is where I’m stuck now. When I load either the Enter Room, Menu, Game (anywhere), the entire screen moves along with my head.

    This was actually happening back when I was using regular Vorpx with the default profile, which caused me to end up abandoning it (even though I’d already had several CP2077 hours using regular Vorpx, which was life-changing and why I’m working so hard to get this to work! It was amazing!)

    I was hopeful that this new mod would fix it, but sadly back here now. Any ideas? (and thanks for all your help so far)


    There has been a Cyberpunk update today that broke compatibility with the modding framework that the VR mod is based on. You have to update the mod to make it work again:

    Cyberpunk VR Update Thread


    Holy hell man. Finally got it working. Spent the last hour or so tweaking and I think I’ve got a glorious sweet spot.

    Thank you SO much for this. Night City already feels completely different. You are the man


    Awesome. Glad you got it sorted.


    well thanks for telling us what you did…

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!