ERR_GFX_D3D_DEFERRED_MEM

Homepage Forums Technical Support ERR_GFX_D3D_DEFERRED_MEM

Viewing 15 posts - 1 through 15 (of 32 total)
  • Author
    Posts
  • #202216
    clint_forward
    Participant

    I just grabbed Vorpx today for the sole purpose of trying RDR2 in VR. It seems to launch and attach but ultimately crashes with the error…

    ERR_GFX_D3D_DEFERRED_MEM
    Out of memory. Please reboot, close other applications, and ensure your computer meets the minimum requirements…

    Gigabyte OC 3090
    5950x
    32 gigs 3800 ram
    Windows 10
    Valve Index set to 90hz
    RDR2 configs set to default
    Afterburner shut off
    Clean boot with no other programs running

    Has anyone else had this issue? I can’t be the only one right?

    #202219
    steph12
    Participant

    hello,

    have you any rdr2 mods ?
    is it fresh rdr 2 install ?
    what’s your antivirus ?
    sorry for that question but did you “mod” your rtx 3090 to have cooler vram modules ?

    btw, it’s working fine for me with the following setup

    valve index
    w10 20h2 with latest updates
    5900x
    rtx 3090 FE
    32 gb 3600
    msi afterburner on
    avast.

    #202236
    clint_forward
    Participant

    Thanks for replying!

    I do not have any mods installed.
    It’s not a fresh install. (do you recommend that?)
    I’m just using windows 10 built in AV
    I did not mod my 3090. But I did install the “resizable bar” firmware update.
    I tried Dark Souls 3 and it’s hooked correctly

    #202238
    steph12
    Participant

    is it the rockstar version ? steam version ? epic version ? try to verify games files integrity ?
    maybe if you have fast internet try to reinstall completely the game.
    try different nvidia driver ?

    i’m not specialist, but right now the game is working fine for me with 461.92 nvidia drivers.

    i dont know where your issue is coming from, but maybe by reinstalling the game that will fix it ? who knows, it’s weird that the game is saying you run out of vram with 24 gb of it…

    #202239
    steph12
    Participant
    #202262
    clint_forward
    Participant

    I’m using the epic version.

    Thanks for the link but it didn’t fix my issue.

    The game does work fine in non Vorpx mode. I was also able to play Cyberpunk in Vorpx without issue.

    Yeah, I realize that vram should not be a problem. I’m swimming in it! :P

    I’m using the 466.11 Nvidia driver. Maybe I’ll try the same one you are using if you think it may help. If that doesn’t work I’ll download it again. Thanks!

    #202263
    steph12
    Participant

    oh wait look here

    https://steamcommunity.com/app/1174180/discussions/0/3145133120119602236/

    maybe you are running rdr 2 in vulkan mode ? you must run it in dx12 mode for vorpx.

    #202267
    Ralf
    Keymaster

    Sounds like some weird conflict. Please double and triple and check whether there really are no other overlays active, e.g. from some chat/messenger app. Just in case.

    Deleting the game’s D3D12 pipeline cache files is also worth a try. Navigate to [Documents]\Rockstar Games\Red Dead Redemption 2\Settings and delete the two files starting with sga_win32_60.

    Afterwards first start the game with vorpX while these cache files don’t exist. If that does not help, start the game without vorpX and load a savegame, so that it recreates the cache file and then try again with vorpX.

    If any of this helps with your issue, it would great if you could let me know.

    #202285
    clint_forward
    Participant

    I understand it needs to be run in DX12. I have double-checked the system.xml file and it’s set to DX12. I also deleted the DirectX cache on every drive.

    I uninstalled Gforce Experience and it didn’t make a difference. The only other programs that I have running are steam VR. No chat programs, etc. I deleted the sga_win32_60 files many times now and a few times deleted all the files in that directory.

    The only thing I haven’t tried was deleting the whole game and redownloading it. Looks like that may be the next step.

    I want to point out that Vorpx has worked in the other games I tried. Cyberpunk and Dark Souls 3 loaded without issue. It’s also worth noting that I think this program is absolutely amazing and already worth the money. I just really wanted to try RDR2.

    I wonder if it has anything to do with the Resizable Bar update? I have no idea.

    Thanks for the suggestions so far!

    #202290
    dborosev
    Participant

    I get this one a LOT too. About 75% of the time, first run, it will give me this error.
    Its made RDR2 pretty much unplayable at this point for me. However, I’m not sure if its 100% the fault of VorpX or not. I got it once without VorpX. There are other mentions of this error on the web, but nothing that has helped figure out what it is. I assumed perhaps vorpX was taking up addition reserved memory or something. And I’m definitely not running out of memory.
    I tried all the above stuff as well.
    I got tired of this error, so I don’t play anymore, but just thought I’d mention it so you don’t feel alone.

    #202291
    clint_forward
    Participant

    The reinstall didn’t work either. I also tried loading the game without Vorpx, created a new save game, then loaded with Vorpx as Ralf suggested. Still nothing.

    Thanks for posing your experience dborosev!

    #202293
    Ralf
    Keymaster

    Would be great if both of you could send a trouble shoot data archive to support at vorpx com. Considering that the game is supported practically since day one and the forum isn’t exactly overflowing with reports of this issue, it’s probably some weird and rare conflict. With a bit of luck cross checking both your system configurations can give some hint.

    @ dborosov: as usual please first and foremost remove any mods and check whether the issue also occurs without. Just as with your keyboard mod last time script hook mods of any kind can cause unpredictable behavior since they may hook into functions that vorpX also hooks.

    #202294
    clint_forward
    Participant

    Ralf,

    I’ve emailed the trouble shoot data archive to support at vorpx com.

    Thanks!

    #203430
    Sipha
    Participant

    I’d just like to say I have just purchased VorpX specifically for RDR2 and get the exact same error on first run.

    I’ve tried clearing DX cache and made sure I’m running in DX12 mode no joy.

    System specs are 5800X, 32GB RAM, RTX 3080 so shouldnt be a problem.

    Would really like a resolution on this as it’s the sole purpose I bought the software.

    Thanks

    #203435
    TheBalt
    Participant

    Okay- this is a shot in the dark, but I just resolved a similar problem where it was giving me a similar error message for another game recently. This is -not- a solution endorsed by Vorpx, I want to make that clear; but, it is a rather simple and typical thing to change in Windows and ‘revert’ if you desire.

    It sounds like the mix of your applications is making you effectively not have enough RAM for what youre trying to do. There is a potential fix we can go over, as long as you have a bit of hard drive space available.

    So there is this thing called Paging File Size. Its basically, to my understanding, a ‘weak’ form of RAM you can utilize Hard Drive space with to give you a little extra memory, which might get you through these error messages.

    this is how to access it and change it in Windows 10:

    1.Go to start bar and type this in
    advanced system settings

    2.Select advanced system settings once it pops up.

    3. You should now be in a Window called “System Properties” and in the “Advanced” tab. There should be a section called “Performance”, click “settings” under the “Performance” section.

    4. Now youre in the window “Performance Options”; click the “Advanced” tab.

    5. Now in the “advanced” tab should be a section for “Virtual Memory”, click “change”.

    6. Now youre in a window called “Virtual Memory”. 99% of the time it is -fine- and correct to just let Windows keep these settings as they are, but, in some extreme cases, helping it out with some extra gigs of Hard Drive space may get a program running that is eating alot of resources (for instance, an advanced game like RDR2 + VR + Background tasks + Vorpx)

    7. Select the option “Custom Size” – and go ahead and go a little wild with it. If you have 20 gigs free, set it to “Initial Size” of “3000”; “Maximum Size” of “15000”.

    8. Make sure “custom size” is selected with your new numbers, (they dont have to match exactly what I put, but those numbers should let you find out whether or not this is your problem)… so Select “Set” after entering your values, then OK. Select Ok in all the windows you can and close out of them.

    9. You may have to restart your computer, this -will- take up Hard Drive space, so if you want that space back, just follow this guide and enter lower numbers or tell the System to take care of it, this isn’t harmful, just a way to give some extra ‘slow’ memory to your PC.

    Hope this helps, but Ive used it to fix a few memory issues in the past. Good luck.

    Heres a link with some pics if it helps.
    https://www.tomshardware.com/news/how-to-manage-virtual-memory-pagefile-windows-10,36929.html

Viewing 15 posts - 1 through 15 (of 32 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!