Far Cry 4 black screen

Homepage Forums Technical Support Far Cry 4 black screen

Viewing 15 posts - 1 through 15 (of 47 total)
  • Author
  • #194362

    Hi :)

    I just bought Far Cry 4, coz I hear it should be a blast with vorpx… And its was cheap ;)
    I started the game without vorpx one time, exited and started it again with vorpx.
    It hooks fine and it did some config for the game. So i exited again..
    I started it again and it works just fine till you the screen, push any button, to get the main menu. Then screen goes black and it won´t turn back on. But the game is still running, there is just nothing in the headset.
    I tried to start a new game to see if it hooks later, but it didnt :(

    Any help?? I have the Uplay version


    I have tried multiple things now and it just won´t work :(
    In the second i push a button to get to the main menu, the turns black.
    The game is doing some login stuff when the screen turns black. And the loading takes forever..

    Please help me :(


    Sorry that I’m not able to answer within 45 minutes 24/7. :)

    I’ll check the game and let you know if I can find something.


    If it is of any use, I am having similar issues as described above. Thanks for looking into it.

    (Current version of vorpx using Ryzen 3900x, RTX2080 Super).


    Can’t replicate this guys. I had an issue that resembled what you seem to experience one time when I raised the resolution, but the next time I booted up the game all worked again. Checked with vorpX in Oculus and SteamVR mode.

    No black screen, all supported DirectVR functions fully working. It should be pretty much just launching the game, raising the resolution in the vorpX menu for better quality, restarting the game once to let vorpX adjust some stuff, and then running the memory scanner when in the game for better head tracking.

    So nothing I can really recommend except some general basics:

    1. Reset the profile to default in the config app and/or do a factory reset.
    2. Try to disable the Uplay overlay. I didn’t have to do that, but I can’t entirely rule out that such an issue occurs depending on whether vorpX or the overlay hooks first, so I might have been just lucky.
    3. Check for potential other conflicts on your PC (e.g. tools that can show overlays in games)

    If you can’t make it work, it would be great if you could send me trouble shoot data archives to support at vorpx com. Please create those in the config app (trouble shooting page) after trying to launch the game. No promises, but I’d like to take a look at your logs and configurations to check whether I can find something unusual.


    Im was not trying to be rude, but it was a bit frustrating when I thought a supported game would work out of the box and its 2nd time I have problems with a Far Cry game.. Last time was Blood Dragon.
    I can make it kinda work, if I delete the vorpx file from the far cry 4 folder in documents, then go to the game and put it in fullscreen.
    When I start the game it hooks just fine, but its very zoomed when I play and I only have a picture in left eye in G3D, if it set in z3d I have picture in both eyes.
    So if I turn it back to windowed mode (sometimes the screen turn black if I go to options and change anything), exit the game and enter the game, it seems to work.
    But if I die, I have to make these steps again to make it work.
    I disabled all overlays I could find (Uplay and Nvidia) and reset the profile multiple times.
    I made one more attempt to enter the game in windowed mode, to make you some log files I can send to you.
    Im not sure what to do now..


    None of that should happen. Please try what I suggested above, and if it doesn’t help I’d like to take a look at some trouble shoot data to check whether there is something unusual. You can create a trouble shoot data archive in the config app and send it to support at vorpx com.


    I have the same issue. Have tried all suggested steps and still have a black screen. The game launches correctly, but the screen goes black after the initial intro screens when the game attempts to reach the UBI servers to log in to your profile. The login attempt happens whether you are online or offline, connected to the net or not, so there is no way to avoid it. Once the screen goes black, it will not return on the headset (index).


    for me the problem is:
    if i change 3d mode, from g3d to z-normal, the game crashes


    I recall having this problem (black screen main menu) when the game first came out, before vorpX. See if you can reproduce this problem without vorpX, I’m not so sure it is vorpX at fault here.

    I don’t recall exactly what I had to do back then, but it may have been something like pressing Alt+Enter to switch to windowed mode before the login connection screen, and then using Alt-Enter to restore fullscreen as “press any key to start”.

    Maybe something fishy about resolution setting, I’m not sure. Might be safe to choose your monitors default, or the standard 16:9 aspect ratio which is most common in games.


    i’ve found this post:

    hat’s a nice trick. Thanks a lot man, I tried every other possible solution to launch Far Cry 4 with VorpX and it crashed at start-up every time. Disabled Uplay overlay, gone offline, disable Steam overlay, MSI afterburner, antivirus, everything…VorpX desktop shortcut for better hook chance…nothing worked. I almost gave up, re-enabled all overlays and tried your solution, resuming Watcher after the loading bar passed 50%…VorpX hooked, launched campaign, tweaked settings for perfect image…works flawlessly.

    Also I might add that Far Cry 4 is a good game to be played with VorpX:
    – minimum zoomed-in effect due to high FOV setting, especially combined with Letterbox 2
    – very well optimized, runs great oh high settings
    – visible HUD in-game on DK2 thanks to VorpX’s Game Settings optimizer for Far Cry 4
    – very nice experience with driving, gliding, combat
    – great graphics, atmosphere, physics…it’s a Far Cry game after all


    maybe restart the pc may work :)


    i go to compatibility (farcry4 shortcut), and checked “disable full screen optimization’


    Hi have you solved? I have the same problem



Viewing 15 posts - 1 through 15 (of 47 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!