Help with Skyrim

Homepage Forums General vorpX Discussion Help with Skyrim

Viewing 13 posts - 31 through 43 (of 43 total)
  • Author
  • #17410

    Oh, ok thanks. I have Nvidia GPU. Processor is AMD however…


    I was able to find a fix for Fallout crashes…sounds quite feasable…you might want to try it and let us know if it solved your problem.


    That fix, as another user noted could be related to GPU or CPU overheating…get a utility to monitor your temperatures while running the game too.


    here is the fix for Fallout 3 – I have 8 cores in CPU so this lowers it to two and it doesn’t crash any more:

    Open up the fallout.ini file in: My Documents\My Games\Fallout3
    Find the line:


    change it to:


    Add another line after it and insert:


    This will limit the game to 2 cores and prevent the engine bug from causing the game to freeze.

    *If the game still crashes write this iNumHWThreads=1



    I was able to find a fix for Fallout crashes…sounds quite feasable…you might want to try it and let us know if it solved your problem.

    Yup found it too after some research, thanks for being helpful, bud!


    SKYRIM – I managed to get Skyrim operating in my DK-2

    I made sure to delete the 9x.ill file from my SkyRim folder. ( these are the mod files that conflict with VorpX ) I’m not 100% sure the exact name of the file but there’s loads of threads in this forum that explain that you need to remove any mod files..

    I made sure that Dk2 is my primary monitor. & I dragged the task bar over onto my laptop monitor so I can still click icons in the task bar.

    In VorPX’s confiuration I set Display/Monitors – to Use “System Settings”
    (not show only Rift )

    I set the Oculus Profile to the profile I created in the Oculus Configuration Utility.

    I make sure to when launching SkyRim to set the Display settings correctly.

    IN-GAme – to get the screen to show all UI elements I simply middle mouse wheel roll & the game screen edges zoom in & out till I can see all.


    Looks all good, just using an Oculus profile is not recommended currently due to a bug in vorpX 0.71, which results in wrong distortion and a too small image with an Oculus profile selected.

    Select ‘Do not use an Oculus profile’ instead and dial in the IPD manually. You’ll get a much better image this way.


    yeah Skyrim is working great! I have about 60 mods now installed and it even looks beatiful. My GTX 680 and 8 core AMD CPU handling Skyrim very well on High settings through DK2. I try not to move the head too much as there is still some jittering going on even though not too much. Smooth like a baby’s butt experience in dungeons and world maps, but if I get into city turning head or looking up or down is a bit jittery.

    I don’t have to run DK2 as primary display. I usually change resolution of my monitor to 1024×1028, and set it to 75Hz and everything is golden. IPD was the only problem in my case. That’s why things looked doubled. Thanks for VorpX. Without it I’d be still poking around short Demos, some are nice but playing a full game like Skyrim is a whole lot better experience. I almost pooped my pants last night while I was going to the dungeon for quest and all of a sudden this black wolf jumps me from behind the tree. What the heck! LOL.

    If any improvements possible I wish VorpX to have “profiles” that can be used in specific games. Like pressing DEL there are bunch of settings to play with while setting VorpX for your best experience. So separate profiles that you can assign to specific game would be great after you play with settings through DEL inside the game and find optimal ones for your eyes and that game, so that VorpX could remember them, or some pre-coded profiles that would change to several optimal settings templates to try etc.

    My main gripe probably is that headtracking gives a bit weird impression, thats probably because Skyrim doesn’t really have OR support and VorpX doing its best. I tried to play with image zoom, and different FOV until found the configuration that I could live with.

    Anyways, keep up the good work Ralp! You have a birght future ahead of you if you can make VorpX support as many best games as possible, especially these AAA titles like Skyrim. IMHO OR will be very popular in gaming community and being able to play old games with OR on would be an awesome change of experience.



    So first off let me start by saying, when I got the rift a week ago, I didn’t know ANYTHING about resolutions and monitors, or what most of the settings meant. I got some games working by google and “What does this button do? Oops” I still don’t know very much and have ALOT to learn. After being frustrated and buying this program or downloading and injecting that mod, and almost regretting buying the Rift because I didn’t know what I was doing, I finally found a setup that works for me.

    I decided that maybe I could help some poor soul out there that’s in my same shoes, kind of get going with Skyrim. So I decided to post this “in no way official, but hopefully at a little helpful to someone guide” This worked for me, but may not work for you. I am literally just listing what I did, and my results. That being said Follow AT YOUR OWN RISK.

    I guess it should be noted that I have NVidia (couldn’t tell you the model or if the settings are the same as your Nvidia) and the settings below are for that graphics card. I’m using Windows 8.1. I have 2 DVI ports on my computer and have the Rift plugged into my left port (if I’m facing the back of the computer) and my Computer monitor plugged into the right one. Also I am not using any visual mods for Skyrim (that I am aware of) Only Skyrim (with all the DLC), Oculus software, and VorpX.

    First open Skyrim without Oculus attached, load a saved game.

    This is important: Change Fov (Field of View) by doing the following:
    -While in loaded game hit the ~ on keyboard. This will open a command screen (I guess that’s what it’s called)
    – Type the following (without the quotes) “fov 120” and then hit enter
    – Hit the ~ again to close the command thingy
    – Save a new file

    The screen will look stretchy without the rift on. You want this because things will be too close while in the Rift if this is left to the games default FOV. This can easily be change back for play without the Rift by following the steps above and changing the FOV back to 65 (the original FOV).

    — I freaked when I first did this because VorpX did it for me. I didn’t know the term “FOV” and I didn’t understand why Skyrim looked stretched when I didn’t have the Rift on. I deleted and re-installed my Skyrim like 3 times, thinking that I broke something, before I researched and figured this out. Whatever, I learned something new.

    Quit Skyrim

    Now, Make sure Oculus is connected, on, and the Oculus Utility and appropriate are drivers installed (not trying to be a smart ass. I’m stating this with the assumption that you’re a complete newbie like me)

    In Oculus Vr Utility, set Display mode to “Extended”
    -Tools -> Display Mode -> “Extended Desktop to the HMD”
    Minimize Oculus Utility

    Then on Desktop, Left Click On Desktop to Open the following Applications:

    *NVidia Control Panel: (Make sure to hit apply and yes after changing each setting) Also make sure that you are changing the following settings for the Rift (not the computer monitor)
    -Resolution set to 948×1080 (Display->Change Resolution)
    -Rift should be to the Left (Display->Set up Multiple Displays)
    Then Drag Rift to left of Computer monitor
    -Make Sure Rift is in Portrait Mode (Display-> Rotate Display)

    * Screen Resolution: (also found by Right Clicking Desktop)
    -Resolution set to 948×1080
    -Rift should be to the Left
    -Rift should be in Portrait Mode
    – It’s weird, I’ve seen NVidia tell me Rift is in portrait, while Screen Resolution gives me a different orientation. Maybe I’m just crazy but make sure the settings in both Display Applications match)

    Side Note: I find that setting Rift to 948×1080 while it’s in portrait mode allows me to see most of what’s on desktop screen. I don’t understand this because I thought Rift’s native res is 1920×1080 but whatever, it worked. (Maybe someone can explain because again, this is completely foreign to me)

    Launch VorpX
    I have the following settings checked for Skyrim: See “VorpXSkyrimConfig” picture in link below

    -Disconnect Xbox Controller (this will be reconnected after initially setup)
    -Make launching the game easier by creating a Skyrim shortcut on desktop and putting it in the center

    After Verifying settings in VorpX, and that both Display Applications settings match, go back to NVidia Control panel and do the following

    -Make rift primary display
    -Uncheck Computer monitor from the list of checked devices (this should turn off computer monitor forcing VorpX aided game to open in rift)

    Your computer monitor should turn off and your Rift should be the monitor. Make sure to click yes to Keep Changes as the settings will revert if this is not done in a timely manner. Hopefully the desktop doesn’t look flipped or weird in the rift. I struggled with this for a while and finally got this sorted out with above settings. Again this may be different for you.

    Next Launch Skyrim
    -On the load screen click Ok with mouse for the health warning and then hit shift+space bar (I found that I have to hit the 2 buttons together and rapidly a few times to get the box to go away. You’ll see what I mean) This may also load your last save, (you probably won’t be able to see the options to the right)

    -Once game has loaded, hit the ‘Del button’. This will pull up VorpX settings. At the top there is an arrow that lets you switch pages of the VorpX settings. I have tweaked VorpX settings on these pages and have left the other pages alone.

    -Click “VorpX In Game Settings 1 and 2” pictures in link below to see settings I used.

    VorpX In Game Settings 1

    VorpX In Game Settings 2

    -Make sure to click “Ok and Save” in VorpX settings menu once finished

    -After filling in settings, Hit “Del” to exit out of VorpX settings

    If you hit the middle wheel of the mouse, it will show you more of the screen (menus and such), click it again to zoom back in.

    -Save game and Exit to desktop.

    -Now plug in Xbox Controller (or not), re-launch game, and it should work. The graphics are not the best but they’re not terrible (in my opinion)

    Sometimes I find that I have to exit and re-launch game if head-tracking stops working.

    Sorry if this post is unprofessional, if I’ve made some grammatical errors, or if I’m hard to follow. This is my first time doing this and was a completely impulsive post. But I hope this helps someone….


    Hi Seelenmord,

    Thanks for the comprehensive guide! Much appreciated. One addition: You can make your life a little bit easier by using the DK2 as secondary display in Windows. This involves two steps:

    1. Set the DK2 as secondary display in the Windows monitor configuration.
    2. Set vorpX to “Show only on Rift DK2” instead of “Use system settings” in the vorpX config app.

    You should also set Skyrim to 1920×1080. Not sure whether you did that, didn’t see it in your post.


    SKYRIM STEAM FOR OCULUS DK2>>> IN CONFIGURE VORPX MENU General settings Device Settings: Oculus Rift Devkit 2. Oculus Profile>Do not use one!! Display Monitors>Show on Rift Dk2. Interpupillary Distance>adjust in game. INPUT> Enable head tracking and roll. Leave third uncheck. MISC> Run vorpX control as administrator. If using steam go into the steam right click properties on elder scrolls game. Local File tab. Browse Local files. Click on Skyrim> on Skyrim prefs right click properties and change to read only if its not already. OK awesome for next part you need to go to nexus mods and download using their nexus manager the Less intrusive MOD 2. It makes life a lot easier in game. ok after that run skyrim you may have to download Skyrim mod SKSE but try it first should work. When you click the game it should send it to your headset now. OH NO U LIED U SOB IM SEEING DOUBLE STILL!!!! FEAR NOT!!! This sounds retarded but it should work. Close one eye and spacebar/click the continue game( Recommend getting past initial part then saving a lot easier.) When your in the game press the delete button. From here you have a ton of options to adjust the display for the rift. At the very top is your settings page. Click the right arrow of the top selection. Look at the new menus bottom two selections. They adjust the split view you are seeing. Simply click the arrows to calibrate or click the bottom selection and use arrow keys to unify the view. TA DA!!!! You can Now play SKYRIM.. YOUR WELCOME WORLD!!!


    Skyrim has always worked for me without having to do anything strange… Just follow the clear and easy to understand vorpx instructions. But if this helps someone then great :) Glad your having fun in vr skyrim!

Viewing 13 posts - 31 through 43 (of 43 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!