Skyrim – Is this supposed to look good?

Homepage Forums General vorpX Discussion Skyrim – Is this supposed to look good?

Viewing 15 posts - 1 through 15 (of 42 total)
  • Author
  • #103469

    Installed VorpX today to try some classic games on the Vive. My PC has an i7 processor and a GTX980 — VR generally looks amazing on this system.

    I did a fresh install of Skyrim, added some recommended Mods… loaded it up with VorpX… and the game looks absolutely awful. Low resolution, low frame rate, latency issues — and it’s all projected on what looks like a big movie screen. (Not theater mode — just a “window” into the world.) Yes, the image is 3D, and head tracking roughly works… but immersive this was not.

    I was expecting to be IN Skyrim.

    Am I missing something here? I played with the settings a bit but couldn’t find anything that gets anywhere close.

    Was I just vastly overestimating what the injector can do?


    You can use any resolution you want. Try 1600×1200 or 1920×1440 if your PC can handle that for the best possible image quality. The default recommendation of 1280×1024 is a compromise between quality and performance.

    If you are seeing a screen in front you in full VR mode, you probably have changed the Image Zoom setting on the image page of the vorpX menu. Please make sure to reset the Image Zoom to the default 1.0 and the aspect mode to Pixel 1:1.

    These are the defaults for Skyrim, and with these settings the whole image is filled, so you are fully in the game. If you already tweaked a lot, it might make sense to restore the default profile in the config app.

    Instead of using image zoom, set the game’s field of view (FOV) to the value suggested for your headset. in Skyrim that is particularly easy. You just have to click the “Adjust FOV” button on the main page of the vorpX ingame menu.

    In regard to performance please make sure to use an unmodded Skyrim and do not use any performance degrading ini tweaks (uGridsToLoad etc.). Skyrim is a highly CPU intensive game, even more so with vorpX in Geometry 3D mode.

    With an unmodded Skyrim and a recent CPU you should be able to get ~50fps in most parts of the map with dips below that in towns (especially Whiterun).

    If you want to enhance your framerate significantly beyond that, change to Z-Buffer 3D in the vorpX menu. Doesn’t look as good, but is a lot faster.


    Guys u really need to learn how to set up the software (yes it will take a while) before going and complain skeptically in forums. It will look very good unce u set it up well, but prepare urself to work around some control issues with that specific game. It may take a bit before u find a really good setup.


    First, you will need more horsepower than a single 980 can provide to the best experience in Geometry mode.

    Try setting you zoom to 68-70
    Both the 3D sliders to 30
    Mouse accel off
    Learning/getting used to Edge Peek is a must

    I have been playing this setup/Settings for a while now on Crossfired 390s. With mods I get from 27 (in whiterun to 45FPS (interiors/some outdoor areas). Looks really good. I’m moving to a pair of 1080s solely for this game in VR. Once you get your settings sorted, it is phenomenal.


    I tried the recommendations above but it really doesn’t feel immersive as compared to native Vive content. The world is not really 3D; head tracking is not 1 to 1; it feels like a hack. Maybe I’m just expecting too much for what is ultimately a hack.


    Hi Ralph
    2 quick questions will you by any chance have a Commercial version of vorpx
    that we can purchase with multiple keys say 5 or 10 pcs at a time,

    also will vorpx be able to run with the new osvr head set

    may thanks paul


    @ borum : For 1:1 head tracking you need to adjust the head tracking sensitivity on the head tracking page of the vorpX ingame menu like described in the Essential Hints guide in the vorpX help. If you didn’t do so already, please read this guide. It also contains other vital infos.

    If you use Geometry 3D, vorpX renders everything twice just like native apps do. With the FOV set up correctly, you get the exact same kind if 3D like in VR games. Z-Buffer 3D however uses a different approach that doesn’t look as good, but on the other hand is a lot faster. So you can to choose whether you prefer performance or perfect stereo 3D.

    @ poppabear : For commercial licensing options please contact support |at| vorpx com.


    Not sure what to say, except that I’ve done all the above and am just not getting a decent VR experience. In geometry mode it looks like “fake 3D,” and it’s barely making 30FPs. Z-buffer looks even worse. Maybe this is playable for some people? It’s possible I was expecting too much. Hard to know what other people are seeing.


    Geometry 3D does 100% the exact same thing as ‘normal’ VR games. It renders two views of the scene offset by a small distance and displays one image to for each eye. That’s also the reason why it’s slower than Z3D, which applies 3D as a post effect.

    If it still does not look correct with Geometry 3D, your FOV might not be set correctly. Please double check that.


    FOV is set to 120.

    Maybe my specs just aren’t high enough? i7 Core w/ Nvidia 980

    I’m getting low resolution AND low frame rate.

    Tough to pinpoint the rest without posting video. Best I can describe is that I don’t feel like I’m “in it” — more like some 3D effect has been improperly applied.

    Might not be worth the fight… I’m not getting the sense things are going to dramatically improve…


    You can choose any resolution you want. The default recommendation is a general compromise between performance and quality. For Skyrim you can choose a higher res though (e.g. 1600×1200 or 1920×1440). It’s CPU bound with vorpX, so a higher res doesn’t impact performance too much.

    Alternatively you can use the “Internal Resolution Upscale” option in the vorpX ingame menu (image page). For Skyrim and a few other games vorpX has this ability.

    With a decent Core i5/i7 and an unmodded Skyrim on medium to high settings you should get ~50fps in most parts of the map with dips below that in towns (especially Whiterun). For significantly better performance Z-Buffer 3D is the way to go.


    Borus your just too bad ass I guess. Everyone I’ve had use my set up with Skyrim is blown away. It’s in the top 5 games for VR. Either you don’t have it set up well or again your just too damn cool. I think you should focus on getting it set up better because if you like Skyrim then VR is just over the top impressively sweet. I don’t know I just prefer AAA games that are actually games and not amateur hour tech demos that Oculus and Vive are hawking as full game currently.


    Would anyone please be able to post all of their settings? I see a lot of “once it is set up it’s awesome”, but it would be a big help if some of you who have figured it out already could help those newer to this program to get started. I know that everyone’s set up is different but even a rough starting point would be better than nothing. If you do feel like posting some settings, could you please post all of the settings and not just a couple of the “main ones”? Once I get it running well I am going to create a comprehensive setup guide but as of right now it feels like absolute sh*t.

    Thanks in advanced.


    The only things that you absolutely need to adjust are field of view and head tracking sensitivity (which is true for most games BTW).

    In Skyrim field of view can be adjusted with a single mouse click in the vorpX ingame menu (main page). If it’s still a bit to narrow afterwards, compensate for the rest with the image zoom setting. Head tracking sensitivity can be adjusted on the head tracking page of the vorpX ingame menu.

    Adjusting these two things brings the game to a playable level. Nothing else has to be changed/tweaked to make the game playable with vorpX. Don’t overtweak things, it’s very easy to cause more harm than good.

    Beyond that you *optionally* can adjust the following things, but none of them are strictly necessary.

    1. The game’s resolution (Higher = better quality, costs FPS though. Try 1600×1200)
    2. The HUD/menu scale. Default should be OK, but you can adjust it to your liking
    3. The 3D-method and strengh (Z3D for better performance, G3D for better looks)


    oh thats easy, im running skyrim in 4k, everything is turned on except shadows *i always hated shadows imo* and antialiasing off too

    thats probably why i’d assume for sure

    mine looks gorgeous, im actually in the game, i was going to make a whole new thread about this, but i just wanted to say thanks to ralf and whoever helped, skyrim in vr has really changed the way i see gaming, these vr devs have no idea what gamers want, THIS is what gamers want

    there is nothing like it in the world, to be ABLE to just like BE INSIDE THE FREAKING WORLD is just……and to be able to do small things like if it was winter in real life, and in the game, i went into a merchant/hotel place, with the fireplace and just sit down and be in the ambience, is just insanely cool, to be able to just go into another world without the freaking phone dying ala gear vr lulz, its just something special, call me crazy but i think vr games shouldn’t be focused on vr, i think games should continue coming out normally but add optional vr support!!!!, or at least a file config to let ralf add vr into it :P
    nah but yeah games should be made normally with both m/k / control / vr optional controls

Viewing 15 posts - 1 through 15 (of 42 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!