Resident Evil 3 Remake

Homepage Forums General vorpX Discussion Resident Evil 3 Remake

Viewing 15 posts - 16 through 30 (of 39 total)
  • Author
  • #193797

    Hi zig. I’m using your profile. However both eyes never align. In the main menu the right eye is strongly stretched horizontally. The left eye is fine. The UI does align on both eyes though. In-game it’s worse. Both eyes are flickering. It’s like the mesh (geometry) is hidden for a short time and you only see the background image of the environment (skysphere). And that happens for both eyes at the same time, but not synchronized.
    My settings are the same as yours but the latest driver available for me was 445.75 on a GTX 970. I’m running the game in window mode. Fullscreen makes it crash at the start with a error message. It tells me the path to renderdevicedx11.cpp and then says 6047 D3D11 create Swapchain failed. (HRESULT: 80004005)
    Does anyone knows how to solve the flickering?



    If the profile was flickering or rendering in one eye I wouldn’t never uploaded to the cloud but there might be another setting your have to change in the re3_config file. The profile is prefect on all the third headsets I tested and looks as good RE2
    The profile is prefect on all three headsets I tested it on True 3D geometry full screen exactly like RE2 remake.
    Below are my setting re3_config file which I think are important
    Below is my re3_config.ini file try this and see if this solves the problem.

    check your setting I think if UseVendorExtention=enable this would cause that error.


    Hi zig11727
    The problem was it! UseVendorExtention=Enable
    But…The performance is too low. It’s impossible to play. Especually in the center of City
    Mu spec: i7-7700K GTX 1080Ti



    Thanks for letting me know I have a super computer setup so on most games performance isn’t a problem but perhaps Capcom will release a patch so now I will include in my notes to change UseVendorExtention=Enable to Disable I going to see if I can DMC5 working with VorpX.


    Has someone already got performance’s problems in Resident Evil 3? I have 10-17 fps on the streets. Launching RE3 through 3D VISION has the same problems about performance.
    My spec: i7-7700K 1080ti


    In case of performance issues your best options are to reduce graphics details in the game’s options menu or switching to Z3D in the vorpX menu.

    If performance issues only occur in certain areas, you can also switch temporarily between G3D and Z3D using a keyboard shortcut. Per default that is ALT+K (can be changed in the config app). Caveat: in some games with more complex engines live switching from Z3D to G3D may cause graphical anomalites, so switching back and forth using the shortcut key isn’t always a viable option.

    More detailed information can be found in the ‘Performance Optimization’ section of the vorpX help.


    I have much more higher performance in the Resident Evil 2 with more higher settings.
    I heard that this problem is not only mine:
    Cite: “Strong CPU limitation (3 core bug?) especially when in the street going out of the metro station in the RE3 demo.
    Framerate goes from 105fps in 2D to < 25fps in 3D (on an old i5 2500k@4.4ghz) with only 35-40% gpu use (rtx 2600).”
    I have much newer CPU, but fps as lowest as him.


    There is no such thing as a “3 core bug”, neither in 3D-Vision nor in vorpX. I am aware that this rather odd myth is fairly popular among members of the 3D-Vision community for some reason, but it’s really just that: an odd myth.

    The actual fact of the matter is that submitting work to the GPU in most current game engines is still largely a serial task. It doesn’t automatically get parallelized just because you use a CPU with more cores. If one core gets maxed out by the main render thread, the whole game is limited at that point, no matter how many cores are left doing nothing. That’s not a bug, that’s just how things work. The only ones who can change that are the game devs by making better use of multithreading in their rendering code (as far as possible, there are limits to that).

    As for your original question, the recommendations I can give you are the ones above.


    So is the aforementioned intense performance hit an unavoidable problem due to the nature of current hardware, and thus likely to affect everyone?

    Is anyone having consistently solid results?

    I’m curious if there are any specific options or quirks to be aware of before diving in later, if any.

    Also if there are any special tests or experiments for me to check out and report back on, I’d be obviously be more than happy to. I’m on an i7@4.4Ghz with an Aorus 1080 Ti Xtreme 11gb. I’ve just completely formatted and reinstalled my entire system, so conflicts and hangovers should be at minimum.

    Huge thanks @Ralf for including this much desired profile officially in the latest update!


    With Geometry 3D you typically see a ~50% performance hit from creating stereo 3D since everything has to be drawn twice (once for each eye). On top of that there is a small overhead (about 10%) from rendering to the headset. Also in many games vorpX can raise the field of view to match the FOV of your headset (that is a good thing), which also impacts performance since with a higher FOV a game has to render more of the scene.

    And as if all that extra work wasn’t enough already, depending on the game there may be situations where an even bigger performance drop can occur with Geometry 3D due to the game engine ‘maxing out’ (see above). That’s probably what is happening here in the more taxing city sections of the game.

    Long story short: especially with Geometry 3D there is a lot more work to do compared to what happens when you play a game on your monitor. That’s just the nature of the beast and also the reason why most native VR games look as if they were made 10 years ago.

    vorpX has a performance friendly post process 3D mode (Z3D) to deal with that. If you want to play the latest games and reducing graphics details is still not enough when using Geometry 3D, Z3D is your best friend.


    That’s a good post and clarification. Thanks!

    I understand completely.

    In terms of Resident Evil 3 specifically, is there anything to watch out for or tinker with to get the profile running as you intended? I’m sure the specifics are in the actual profile’s description, so apologies if I’m asking for extraneous or existing information. I’m not on my VR rig to check the in-app vorpX cloud list until later but beyond curious about the game’s general performance and what visual tradeoffs if any might be for me in Z3D/G3D.

    I’d be happy to just play the whole game in Z3D in Immersive Screen or Cinema mode, I think. Especially if it means I can keep the main art assets and effects on a high setting and keep reliable performance. Should be fine, right?

    As an aside: If I could, I think I would happily play every game in Z3D. I’m genuinely struggling to play games in pancake at the moment. It’s a pretty damn excellent problem to have! VR is just so goddamn good. Even generic 3D depth is delicious. VR has genuinely changed everything for me!

    I’ve not had much luck getting basic Z3D running on any games without profiles yet, e.g. Yakuza Kiwami (I copied the Yakuza 0 profile but no success) – but it’s something I’d like to eventually master.



    I haven‘t played through the whole game, but I‘d be surprised if you would run into serious performance issues while using Z3D. I don’t think you will have to take care of anything special with Z3D.


    Fantastic! Cheers Raffers. <3


    Siiigh. No luck with Resident Evil 3. I’ve been trying out all sorts, but unfortunately after successfully hooking and seeing the game window pop up with the VorpX logo at the bottom, an error message triggers:

    “Direct3D 11 fatal error: SwapChain failed. [ OK ]”

    Pressing OK closes everything.

    Is this something you’ve come across before perchance, Ralf? The usual applies; I have no naughty programs open, SteamVR game options have overlay and desktop theate turned off. Windows Security off. Edit: I see vergilldc is/was having the exact same error message in this thread (the post at the top of this page) back on April the 12th, 2020.

    So the hooking seems to be all OK, but I’m guessing there’s some kind of hand-off function to the game’s render calls that’s refusing to play along and dance.


    Nope, didn’t encounter this. Running the game windowed might be worth a shot (or fullscreen if you currently are running it windowed)

Viewing 15 posts - 16 through 30 (of 39 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!