World of Warcraft screen squishes after a while

Homepage Forums Technical Support World of Warcraft screen squishes after a while

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #208484
    swatt
    Participant

    Hi there,

    I hadn’t played in a few months until now. Now I have a new video card, WoW has updated, VorpX has updated… now I’m having an issue.

    Basically, all works perfectly. Immersive screen mode, full 3D, it’s awesome. But after a while, the screen inside VR just squishes. It looks to be about half width. The mouse cursor is gone. I can still click things, just can’t see the mouse cursor.

    If I stay in VR, and switch to Fullscreen mode, it is good again. Then after a while the same happens again. If I then switch back to Windowed mode, it is good again. So both modes work, but not forever, and switching between them fixes it.

    Under Advanced in WoW, I’m in DirectX 11 Legacy mode, as I understand it should be. The other choices are DirectX 11, and 12.

    Under Graphics in WoW, I have Window Size at 3840×2160, which is my screen resolution. Then under Resolution Scale, I have moved it down to 72% / 2773×1559 so it can render performant in VR. Otherwise, graphics is on 10 / Ultra.

    Is there a fix so it doesn’t squish after a while? When it squishes, it shows a lot of moire and looks really terrible.

    Thanks!
    Sandra

    #208486
    Ralf
    Keymaster

    I’ll take a look at that early next year. For the time being I just have a potential workaround unfortunately:

    With the ‘Play Style’ option set to ‘Cinema’ you can choose a manual aspect ratio for the screen under ‘More Cinema Settings’. That might help with the squished image, but probably won’t with the cursor problem unfortunately. Worth a shot though. For your display res you would have to set the ‘Screen Aspect Ratio’ to 16:9 instead of Auto.

    ‘Cinema’ mode can be set up to look pretty similar to immersive mode by changing the Scene to Ambience or None.

    #208491
    swatt
    Participant

    Ok, I can try it out.

    I also found out that in WoW you can bind a key to switching between Windowed and Fullscreen mode! So now when it messes up, I can just press the key, and continue.

    So I have 2 workarounds. Thanks!
    Enjoy the holidays!

    #208863
    dennis
    Participant

    I bought vorpx today to run world of warcraft and I am having the same exact issues. When a fix is made is it automatically download or do i need to keep checking back?

    #208877
    Zander
    Participant

    yes, a fix soon…hopefully =)

    #209011
    Tophness
    Participant

    Had the exact same issue here for over a year. WoW was the main reason I bought VorpX and a WoW subscription so this is really disappointing. I’m just using a key binded to window/fullscreen toggle and press it twice every time it happens, but it makes the game relatively unplayable in battle. Really hoping this gets fixed.
    Outside of the forums people have been complaining about this for a long time.

    #209012
    Tophness
    Participant

    Mouse cursor is also always offset for me. I’m using 1920×1200 resolution. At 4K with scaling the lag makes it unplayable but the cursor is accurate

    #209015
    Ralf
    Keymaster

    I’ll take a look at that before the next update. For the time being I just have a potential workaround unfortunately:

    With the ‘Play Style’ option set to ‘Cinema’ you can choose a manual aspect ratio for the screen under ‘More Cinema Settings’. That might help with the squished image, but probably won’t with the cursor problem unfortunately. Worth a shot though. For your display res you would have to set the ‘Screen Aspect Ratio’ to 16:9 instead of Auto.

    ‘Cinema’ mode can be set up to look pretty similar to immersive mode by changing the Scene to Ambience or None.

    #209043
    Tophness
    Participant

    Another issue I’m sure everyone has seen is water rises above the head and turns invisible. Makes it really hard to see things sometimes

    #209047
    Ralf
    Keymaster

    That sounds severly weird, never of it before. Please check whether positional tracking is enabled in the vorpX menu (head tracking page). If so, check whether disabling it resolves the issue.

    #209198
    davidnicholson
    Participant

    Hi Ralf, Just to add to this thread it is exactly the same issue I was having with WOW in this post https://www.vorpx.com/forums/topic/wow-mouse-cursor-disappears-after-10-minutes/.
    It is exactly 10 minutes when this happens if that helps and switching res brings it back for a while. The post explains a little more of what I observe when this happens.
    I am willing to work on an beta fixes or troubleshooting with you on this.
    I have a development background and have tools like VS2022 installed, etc.
    Everything else is perfect if we can get this fixed.

    Thank you kindly.

    #209200
    davidnicholson
    Participant

    Just to follow up, just doing a /run RestartGx() brings back the cursor. No need for screen res changes.

    #209523
    swamibob
    Participant

    Hi all. New the the community as I was about to buy VorpX but decided to read the forums to make sure WOW was working fine with VorpX. Now I see this and I’m taking a wait and see approach. Has this issue been fixed? I don’t want to get VorpX and the be disappointed that it keeps messing up in wow, since that is the whole reason I am going to purchase it. I can currently play in 3D messing around with reshade but I am looking for a more elegant method with hopefully more options/better 3d effect.

    Has it been fixed yet or is this going to be a hard issue to figure out?

    Thanks

    #209543
    Ralf
    Keymaster

    You can deal with the glitch fairly easily by binding a key to switching between windowed and fullscreen mode as suggested by swatt above:

    I also found out that in WoW you can bind a key to switching between Windowed and Fullscreen mode! So now when it messes up, I can just press the key, and continue.

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!