Does Half-Life 2 still work?

Home Forums Technical Support Does Half-Life 2 still work?

Viewing 15 posts - 1 through 15 (of 34 total)
  • Author
    Posts
  • #180006
    ac
    Participant

    Hi Ralf, I have written earlier but no answer yet. Big thank you for this program.

    All games work perfectly Witcher3, Mass Effect’s and other.

    But I won’t play in HL2,ep1,ep2, black mesa source and I read on the forum what other people can play in it but not me. What is my problem?

    Vorpx is injected and on the monitor display – I see logo Vorpx but in Oculus headset I see only logo HL2 and text “loading”. Cursor follow by my headset.

    I use a cloud setting. Trying with steam VR and without – with steam and no steam – hl2 update, hl2 classic, ep1, ep2, black mesa – result only one – “loading” text and game logo in the white room in Oculus headset.

    Windowed, fullscreen, 4:3, 16:9 and other resolution… no matter.

    Windows 7 x64. Oculus Rift CV1. Last update for Oculus and Vorpx.

    Please help me if you can, I’m waiting for your answer. Thank you, regards.

    #180029
    Ralf
    Keymaster

    Still works fine here with the latest HL2 update from a few days ago in both Oculus and SteamVR mode. Surprisingly even the pre-cached DirectVR values still work after the update.

    There is no need to download a cloud profile for any of the games you mentioned in your post. vorpX comes with fully working DirectVR profiles for all of them. To make sure the right profiles are used please either revert them to default or do a factory reset on the trouble shooting page of the config app.

    #180721
    EpicDimension
    Participant

    I have the same problem, since the last update.
    No Source Game is working anymore (a couple
    of months ago i was playing DoD Source)
    Now, every Hl2 mod is showing a
    Black Screen in the headset.

    The overlay is here, but i had to
    download the cloud profile because
    prior to that it was not
    hooking to the game.

    Please Help.

    #180723
    EpicDimension
    Participant

    https://drive.google.com/file/d/18b9mLC9AvCcWbojYFO0tY3d1ka9CnWXd/view

    I reinstalled VorpX, verified game integrity
    an also tried beta version of steamvr
    i think this came from one of its
    updates and not the HL2 ones

    It seems the HMD is
    not being detected.

    What to do next ?

    #180725
    dellrifter22
    Participant

    I just tested HL2, Ep 2, and DOD:S and they seemed to be working fine with steamVR Pimax.

    Are you both using Rift?

    Maybe not related, and It’s been more than 6 months since I tested this, but you could try renaming or removing “openvr_api.dll” from the game’s bin folder and see if that does anything. This was causing the game to insta crash on launch for me months ago.

    #180737
    EpicDimension
    Participant

    No, I’m using Htc Vive, and already removed the openvr dlls
    from all the source games (at least wich i tried to run)
    I’m testing only with hl2 for now, there is a message
    saying I need to empty or disable the cache to
    Re-scan, but i think is not about that.

    Tracking is working, but i can’t just
    see anything in the hmd, not even
    the menu of VorpX, so i can’t
    make changes to the config.

    I think this already happened before:

    [Unsupported Games] Some DX9 games not terminating properly

    VorpX and Vive and Source Games Technical Issue

    The message I see in the logs is the same:

    INF: ProgState: First Time Init 1
    INF: Vive Controller Manager: No controller found
    INF: Vive Controller Manager: Initialized
    INF: TrackerOpenVR: Init
    INF: OpenVRDirectModeManager: base initialized, mode: extra thread
    INF: OpenVRDirectModeManager: renderer initialized.
    WRN: OpenVRDirectModeManager Submit Error: 101 101
    INF: MemScanManger: cache readiness: r:t p:t f:t
    INF: SettingsUI: Init

    – No Controller Found
    – Submit Error 101

    It is probably happening with more games,
    but i think it will be simple to solve
    once the bug is located, but i have
    not enough experience with this.

    to finish: I have an AMD RX480 4GB
    and also Updated the Drivers
    recently, can be the cause.
    19.3.3 but there is a
    19.4.1 i don’t want
    to update yet.

    Thank You.

    #180738
    Ralf
    Keymaster

    Please try a full factory reset in the config app. The games should hook fine normally. If the factory reset does not help, please check the stickied trouble shooting thread above, especially the part regarding conflicts with other programs.

    Judging from your log nothing unusual is happening, vorpX hooks the game and starts rendering to the headset, the 101 Submit error is perfectly normal and happens with every game on the first frame. Until you see it more than once, it doesn’t mean anything.

    As far as the log is concerned everything looks correct, so unfortunately it is of no help here.

    #180741
    EpicDimension
    Participant

    Okay, so I will start testing today …
    I’m a freak of game optimization

    Of course, i already did a bunch of
    factory resets while reinstalling
    and uninstalling VorpX, nothing.

    But I will try to close every program
    i can, it seems there is a conflict.

    I will update this thread
    if i find it. Thanks.

    #182976
    ENBSeries
    Participant

    Hi, new user here.

    I have the same problem, in Oculus CV1 can see only usual white field with starting Half Life logo and floating text, no actual game or Valve logo. But desktop game looks okay, just no menu of VorpX when pressing Del and game cursor disappear forever after pressing Del (can see tips and VorpX logo too). Tried to run game in windowed mode – no difference. Also i can hear all sounds of game in the helmet and in some way positioning of helmet apply to the game environment, but no rotation. Other games tried and seems working okay. I tried as suggested here to reset factory defaults, i don’t have any incompatible applications (i know how to keep system clean from trash which injecting in to the games), but no luck.

    Win7 x64, Steam version of HL2, GF1060 391.35 driver without telemetry, ansel and other useless things.

    #182988
    Ralf
    Keymaster

    One thing you could try is running vorpX in SteamVR mode instead of native Oculus, that may help with some arcane issues.

    Also try to run the game windowed. Whenever that is possible for a game I would recommend to do so.

    #182998
    ENBSeries
    Participant

    Thanks for reply. I tried both these things earlier, now once again – no luck. In SteamVR mode the only difference is that in helmet everything is black, no sign of rendering and on main display still no proper tracking, same notifications by VorpX, even game hud can be scaled up/down by hotkey, yet nothing better than via Oculus mode.

    #183034
    Ralf
    Keymaster

    Apart from the trouble shooting guide all I can really recommend is sending a trouble shoot data archive to support |at| vorpx com. Maybe the vorpX logfile contains something useful. You can create a trouble shoot data archive in the config app.

    #185633
    EpicDimension
    Participant

    Excuse me, but i was not able to do Hl2 Work again yet.
    I tried everything, inclusive updating drivers a
    couple of times, also steamvr, i hope
    it was temporal, but not. I tried
    stopping a lot of services and
    applications, but i can’t
    still find the culprit.

    There are some suspects in my list
    maybe one of those hooks are
    still running although i
    closed the executable
    or the service but
    I am not sure
    wich of them

    By the way, it is
    Windows 7 x64

    Anyway, i’m sending right now
    a troubleshoting archive
    to the support mail.
    Please, check it.

    Thanks

    #185640
    Ralf
    Keymaster

    Your logfile only contains an entry for Day of Defeat, not Half-Life 2. While the game also uses a hl2.exe, there is no guarantee that it works with the Half-Life 2 profile. The Day of Defeat hl2.exe is probably very different from the .exe of the actual Half-Life 2 since it was forked a long time ago.

    Please check whether the issue also occurs with Half-Life 2. The actual Half-Life 2 should still work fine.

    Apart from that try to run the game windowed if you didn’t try that already. That can help sometimes with display issues.

    In regard to potentially interfering background programs the best thing you can do is closing everything and check whether your issue still occurs. If not, re-enable your background programs one by one to see what caused the issue.

    #185644
    ac
    Participant

    Hi, your problem is Windows 7. I have same problems. Do all what I can, but nothing help me. After this I install windows 10 x64, and all worked perfectly. https://www.youtube.com/watch?v=LwZ6MmSA0PA

Viewing 15 posts - 1 through 15 (of 34 total)
  • You must be logged in to reply to this topic.