Little Trick for Xbox PC Game Pass Players for OuterWorlds

Homepage Forums General vorpX Discussion Little Trick for Xbox PC Game Pass Players for OuterWorlds

Viewing 15 posts - 1 through 15 (of 46 total)
  • Author
  • #188667

    Okay, so Xbox Game pass on PC requires you to launch this application, Xbox Console Companion and the files for these games are under Program Files – Windows Apps..

    Anyways, Vorpx, by default, will NOT attach to TheOuterWorlds.exe – Microsoft has some serious security on this stuff and for whatever reason, Vorpx gets denied even if youre signed in as Admin to ‘attach’ it to the game.

    So heres a trick to get around Microsoft’s BS. Go to your desktop, just hit “Create new text document”.. Rename that document to TheOuterWorlds.exe (itll say itll create a corrupt file or whatever- doesnt matter, just make it)

    Thanks for our good man Ralf’s brilliance – this will make Vorpx look for ANY TheOuterWorlds.exe being launched – even the real one, despite the fact that Microsoft locked it up behind super admin BS.

    So, long story short, if you have Xbox Game Pass on PC and you cant get Vorpx to attach to the file itself, fuck it – just make a text document, name it the same as your game .exe, and, Vorpx, being the brilliant program it is – will hook into the ‘real’ game when you launch it.

    I just put the Conarium profile on The Outer Worlds, havent played it yet, but launched successfully in Vorpx and we can figure out the ‘ins and outs’ of getting it to run well later.

    but wanted to give this heads up to my Vorpx brothers and sisters. Love yall, let me know if my explanation was bad, ill try to explain it better if i failed to make sense :P


    Just a heads-up that you will still encounter some game pass games that vorpX won’t be able to hook although theoritically it could. Until recently MS only allowed UWP (Universal Windows Platform) apps and games in the store. Those typically have some extra protection built in, so if a game dev created an UWP .exe for their game pass version, you’ll probably be out of luck. Luckily they now seem to allow ‘normal’ Windows apps/games too, I’ll try to find a general solution at least for those.

    There is another problem with game pass games BTW: For many supported games vorpX can automatically change .ini files. Unfortunately for some game pass games the paths of these .ini files differ from Steam/GoG etc. releases, so vorpX can’t find them.

    I will adjust the more important profiles, but expect this to be an issue at least for now.


    Thanks for clarification, Ralf. i kinda jumped the gun with being psyched seeing it launch in vorpx, didnt realize those limitations on it, appreciate it!

    I suppose these limitations may mean i need to get some of these games on steam/gog if i cant get a good setup on game pass, thanks for letting us know


    Keeping things up-to-date for different stores, constant game updates etc. slowly starts to become a full job on its own. Somes things really were better in the past.


    Does this issue not apply if you get it through the Epic Games store instead and does anyone know if the EG version hooks/works?


    Almost certainly not. The specific issues above are pretty much Windows Store / game pass exclusive. Doesn’t mean that the Epic Store can’t introduce some other glitch, but that’s less likely.

    Be aware that either way the game has no profile yet. I have it on my list with potentially good candidates though. So if possible there will be one shortly. As always with sentences like the last one emphasis on *IF POSSIBLE*.


    Thanks Ralf!


    Well, just for the record, spent some time with it on the Xbox Game Pass store and it starts – and runs in 3d if you import Conarium along with its DirectVR settings – game is in 3d and appears to look functional, adjustable field of view and everything, got it looking pretty good… but it crashes after about 30 seconds – 2 minutes of gameplay.. no clue why.

    I tried playing offline, tried playing thru Steam and launching Xbox app that way, but, just couldnt get it to not crash. Its a shame too cause I really think its pretty much up and ready to go, the settings made the 3d as effective as any other game, but, alas, it just crashes.

    I tried importing Conarium without the DirectVR settings and it wouldnt allow any sort of adaptive/normal 3d, with the DirectVR settings, it allowed those options and made the game 3d, but, we get the crash.

    Some other profiles may or may not work, let me know if anyone finds a workaround.

    For the record, the crash happens AFTER you make your character and go thru the opening cinema and first get control, you can see the game looking great and running smooth – but crash will happen after a few moments unfortunately

    If anyone finds a trick around this, feel free to share! lol


    come to think of it – i didnt try swapping between adaptive/normal 3d modes when it was crashing, that could be a culprit.. i dont have time to do more testing now, but if anyone wanted to give it a shot, feel free


    Okay, I may be jumping the gun, but just had the game run on Vorpx’s Conarium profile, DirectVR settings included during profile creation, set to Normal 3d, NOT Adaptive and didnt have it crash for 15 minutes, just quit out to make more changes, but game might be stable.

    Not sure if thisll work permanently but its better than it was earlier


    Okay – just so everyone knows whats going on with this game if youre trying to get it running with Vorpx Conarium’s profile.

    The game, as far as i can tell – has a memory leak. You get no error, no code, Vorpx hooks in just fine, but after a few minutes, game crashes.

    I have now tried the game 3 times without Vorpx/Oculus/Steam running and have crashed 3 times without any of those programs involved.

    I saw some people say they were seeing less crashes with setting themselves to 60 fps max, and i did see the game ‘last longer’ on that setting, but the result, in Vorpx or not in Vorpx, was eventually a crash.

    I am not an expert in tech stuff, but when ive seen this issue arise in other games (crashing after an indeterminate amount of time, anything as short as 2-3 minutes, as long as 15-20); it usually ends up being a memory leak.

    If anyone finds a way to fix this or they patch it up, I think the game will run just fine in Vorpx through the Game Pass store and the method I have outlined above with connecting it to Vorpx with a ‘fake’ text document and using the Conarium profile w/ DirectVR settings ‘checked in’ when you create the Outer Worlds profile.

    Sorry i couldnt find a fix for this today, but the game appears to look great in 3d and run well – but i think what we are looking at is an engine issue we will just have to wait for them to resolve.

    All that being said – if you want the game to run properly w/ proper headtracking – you cant just use an xbox controller. If you default to controller, you lose the ‘mouse look’ of the headset and thus headtracking. You will have to use a third party software, I was using GloSC, tying it to my ‘desktop configuration’ and making the game think i was launching with a mouse/keyboard when i was really using my PS4 controller’s configuration, launched Xbox Console Companion thru Steam.

    So – i think this is unfortunately a bug we wont be able to squash today due to an issue with the game itself, not Vorpx or it’s profiles.

    if anyone finds a fix for this, what i assume is a memory leak, please feel free to add it here!

    Thanks everyone for your time, sorry if i wasted it with my rambling today but was trying to help us get this bad boy up and running – if you got it, go ahead and launch it and check it out, it looks good with the Conarium profile.. but it probably wont hold for very long. So i dont think my crashes earlier had anything to do with Normal vs adaptive 3d in Vorpx, just memory leak by the game itself.

    Let me know if anyone finds any other insights! take care everyone!


    Okay – update – i think I figured out a fix for the Xbox PC Game Pass Console Companion players and the game should run fine now.. if you were experiencing the same problem I was. I thought it was a ram leak, as you can see from my previous post, but after watching task manager a bit more closely i think i found the culprit AND the fix, all without having to mess up your PC or download any software or go into any INI files.

    Okay, so i have been messing with the game for awhile and getting crashes every couple minutes of playtime. I thought it was a memory leak issue, as i said before, totally wrong now.

    Okay, so when you Launch Outer Worlds, if you have you task manager open you will see it doesnt JUST LAUNCH Outer Worlds, it launches TWO seperate applications (this is the most important thing, this separate application is what is killing your game, and i think i found a simple work around for it)

    So the second application, should, if you have Task Manager up AS YOU LAUNCH Outer Worlds, it should be called – IndianaWindowsStore-Win64-Shipping.exe . This is the culprit, its not a malicious program or anything, but this is why we are crashing.

    So, as soon as it pops up, right click it and go to Details, immediately. From there, right click it again and go to Services. I was able to identify what it was -trying- to do mid game, but the services it was trying to access were not automatically enabled on my PC, for whatever reason, Xbox Console Companion just didnt turn these things ‘on’.

    So once youre at services, at the bottom of the page should be a series of Xbl and Xbox labeled services. Right click each one and make sure it is set to “start”, some of these were not “on” for my PC by default.

    In reality – i managed to fix this is one run thru and i dont wanna lie, i might have missed a service and if i did, im sorry, but i have no way to replicate exactly what i did, but i got the gaming running, no crashes, switching between ultra 4k textures to lows, mediums and in and out of full screen and full screen windowed without crashes for an extended period of time. I think we were just running into an issue of Xbox Console Companion being a new app and maybe the devs were just dealing with a later version than ours is by default and those services were just ‘clicked on’ already on their end, or something along those lines.

    If you want to be completely sure, just go thru and enable pretty much every microsoft service that isnt running – there might be others that are ‘pinging’ the store, but, if you dont believe me on a cursory glance, just open OuterWorlds and look at the Task Manager and see that second exe file going to “Not responding” randomly – thats whats breaking the game, its pinging for these services, not finding them, then just eventually killing the game.

    Atleast thats the best i can make of it so far – and none of this is digging into your harddrive or destroying any of your files, you can turn all these services on and off as you see fit – but i think the ones to target are going to be the ones labeled Xbl and Xbox labeled ones and then, I think, you should be good to go.

    Good luck to anyone else who was having the same issue – i think youll be able to unlock your framerates and everything else too, i think this was the problem, i saw people saying 60 fps was helping stop crashes, but i think youll be able to pop above 60 now.

    Take care, hope this helps someone

    EDIT, might make a difference or not :just tried testing it again – when you right click IndianaWindowsStore-Win64-Shipping.exe – its unorthodox, but set its priority to “real time” – again, i was crashing all day and these changes worked for me. good luck


    Thanks for testing this. I might jump back in to gamepass again.

    Wasn’t planning to buy this one full price, so this might get me to try it. Sounds like most people are liking it.


    Can’t say anything yet to the game’s potential memory leak, but you can address the head tracking issue without another program. Maybe that helps.

    If a game does not allow mouse and gamepad to be used at the same time, but you want mouse control for vorpX‘s head tracking and still use your gamepad, you can activate vorpX‘s built in gamepad to mouse/keyboard mapper on the input page of the vorpX menu. The option is called „X-Box Gamepad Override“.

    BTW: You can also map mouse/keyboard actions to your VR controllers in a similar manner if you prefer those over using your gamepad.


    Just a heads up,
    The game works fine , no crash at all, i’ve just created a text file named IndianaWindowsStore-Win64-Shipping.exe, then i’ve used the conarium vorpx profile , add IndianaWindowsStore-Win64-Shipping.exe et voilà…
    Very good G3D, it needs a few weaks to be perfect.
    Thanks The Balt for your Tips , i will try this for other gamepass games.

Viewing 15 posts - 1 through 15 (of 46 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!