Stuck at infinite loading in my oculus interface

Homepage Forums Technical Support Stuck at infinite loading in my oculus interface

Viewing 15 posts - 1 through 15 (of 38 total)
  • Author
  • #194379


    I know it can work…

    I have an Oculus Rift S.
    First time trying Vorpx with battlefront 2 work instantly!
    But since then, i have encounter problem with my oculus rift.
    Taking 2 days to fix it finaly by simply bypass the proximity sensor check…
    But i have tried multiple times to reinstall oculus app, my Avast Antivirus, and my Comodo firewall.

    Now that my Rift S work again, want to try Vorpx again. But i’m just stuck in the oculus environment with the store, the library ect if you see…
    Try to launch the game with vorpx open, the load screen into the oculus environment with rift on my head appear, with the little battlefront 2 screen and saying it’s loading, but it’s stay stuck at this point…
    On my regular monitor the game launch well, with every vorpx things it seems, but into the headset, just “loading”…

    I had desinstalled one more time my antivirus and firewall, disabled every in-game overlay and run with the minimum apps possible open, but still don’t work anymore… Have also tried Monster Hunter World Iceborn, but same result…

    Have an idea please?



    Proabably your AV program. It’s one of those that are known to cause trouble on a regular basis.

    vorpX “injects” other programs which some av programs may classify as malicious behaviour without really being sure about it
    Try to disable it ad if that helps exclude the vorpX program folder from scanning.

    Alternatively you might want to consider switching to Windows Defender, which provides excellent protection without being as invasive as some other AV scanners. Windows Defender gets enabled automatically on Windows 10 when you uninstall redundant third party AV programs


    Oh thanks for your answer, and scuse my bad english :
    I was meaning “I had uninstalled one more time my antivirus and firewall”
    So it’s actually already off… My french side.

    So, what can i do now please?


    I’m not sure whether Monster Hunter World still works. Some user recently told me the game now has some anti-hooking protecten, but just yesterday someone else said it should still work when set to DirectX 11. So that might be worth a shot.

    Battlefront II will definitely have to be set to DirectX 11, although normally vorpX should be able to do that automatically in this case.

    Apart from that please check the pinned trouble shooting guide on top of this sub forum. If you experience hooking issues with multiple games, the most likely cause is a conflict with some other program on your PC. The guide has more details in this regard.


    Yes, have set DX11 of course.
    Life is Strange also not working anymore…
    Have already consulted and used the troubleshooting guide without success.
    Have tried to close all the process i can in the task manager still not working…

    Since i have tried to fix my rift s, and while that time doing multiples re-installations of both oculus app, avast antivirus and comodo firewall, it don’t work anymore i don’t have a clue why.
    So now, i don’t know what have changed att all except that i’m actually without security software, and have to manually bypass the “proximity sensor check” to wake up my rift s.

    Thanks if you have a solution.


    Can’t really say anything to to your proximity sensor issue, better ask that question on the Oculus forum.

    You neither need an invasive third party AV program nor a third party firewall on Windows 10. It comes with both. If you uninstall your AV program, Windows Defender kicks in, same for the firewall.

    Can’t really suggest anything more than above, sorry. Hooking issues almost always are related to a conflict with some other program on your PC that also hooks into games, so please double and triple check for any background apps you may have running.

    Apart from that checking the ‘Alternative Hooking’ option in the config app might be worth a shot. Be aware though that some games require the normal method, so even if it helps, don’t forget to switch back.


    Hello again!

    So, since then i have tried 3-4 times to solve my issue (multiples hours per try…) without sucess…

    So, i’ve tested all i can think of, and it still don’t work.
    I can’t list everything, but today tried again multiple times after uninstalling my antivirus, my firewall, my oculus client, vorpx and my GPU driver.
    Then re-installed in this order : GPU Driver => Oculus client=> Vorpx. No security soft so.

    Nothing running in background, minimal processus possible, it just still don’t work i’m a bit tired of this… because Vorpx seems incredible if it just want to work again!

    If i have explained my proximity sensor issue last time, it was simply because it’s since then that vorpx is no longer working anymore. Althought, before that it was working perfect directly, without any tricks needed and i don’t even closed all processus possibles, and even my Avast antivirus and my Comodo Firewwall was running in same time without problem!

    So i don’t know at all why it don’t work anymore today, and i tought it was a good idea to explain my proximity sensor issue if it can be related to this… Also, when was working i don’t have the opportunity to test it a long time, cause i was just new in VR world with my first VR Headset bought recently.

    Here is some other symptoms i can report :

    -Can’t resize the Vorpx configuration windows, and text are often cutted or melted. For exemple the “start page” is just not readable/clickable cause of this, or in “general”, i see only half the text on the device selected, and only the first line of the bottom test is visible.
    -The desktop viewer DON’T WORK EITHER!
    -Tried Monster Hunter World for exemple : I can see the Vorpx Logo and informations on my flat regular screen on the game, and i see that i can even move the cursor in the menue by moving my Rift S !
    -When i try a full factory reset, i have an error message : ” 1 error(s) detected during factory reset. The reset may have failed or be incomplete.”

    So please help me… I’m getting tired of this!
    I can tell you anything you need, send logs ect… to solve my problem please.
    And scuse my english!


    Maybe worth a try running in steamVR if you haven not tried this already. Yes, oculus headsets work with steamVR also.

    If you have steam installed, and steamVR also installed, simply put vorpX into SteamVR mode in the Device selection drop down menu of vorpX Config app, click apply and it should restart your vorpX.

    Then try launching your game and see if it is any different.

    Also try launching the game with the hmd already on your head, as you say you possibly have some sensor problem?


    @ Picdelag

    First please make sure that you are using the latest vorpX 20.2.0

    That out of the way:

    re your actual issue with vorpX: If the issue is related to your proximity sensor, I’m not sure how vorpX would be able to handle it otherwise. It just checks whether the headset is active and if so displays the game, using pretty much boilerplate code from the Oculus SDK.

    If dellrifter’s suggestion doesn’t help, I would as a first step suggest to check whether the issue also occurs with vorpX set to ‘Generic 3D Display’. That way you could determine whether there is some general hooking problem or the issue is related to your headset. If games also don’t work with the ‘Generic 3D Display’, check again for potential hooking conflicts.

    re your config app issue: If you are on Windows 10 and have a high DPI monitor, please make sure that you do NOT have changed any high DPI compatibility setting for the config app. Current Windows 10 builds handle the config app perfectly per default on high DPI monitors. If you are still on Windows 7, you might get a better result on high DPI monitors with one of the manual compatibility overrides. I still check vorpX occasionally on Windows 7 although it is past End-Of-Life for half a year now, but non-critical stuff like this won’t be addressed for a 10 years old OS that not even its manufacturer supports anymore.




    Thanks a LOT dellrifter22, i am really grateful for your help!
    This is your solution that solved my issue…
    I feel stupid to not even have mind to try it before…
    Was thinking “No way i have to change this setting, i have an oculus, i just set oculus…”

    Please Ralf, never remove this option for other VR headset!

    About my proximity sensor issue, it’s a strange and crazy story for how it happened, how the oculus support was just dunmb, and how finaly i have fixed it in 2 clicks afters 2 entire day trying to solve this issue…(of course, oculus support not able to tell me this possibility i was not even thinking possible, that a ‘debug tool’ were availaible in a folder and it have just an option to “bypass proximity sensor check”… So eveytime i want to play in VR, i have to set this to on, and the oculus display things without a pause so.

    Just to say : One day RIFT S work perfect, just saw an update and a new firmware right after removing the headset from my head after a session => installing the update => Rift S never woked up like usual before since this tragedy… have to bypass manuelly, and the oculus support my god… after everything i said they don’t even think of this simple solution and tell me to re-install x times, that maybe it’s an Nvidia issue ect…

    So all this story just to say :
    There is a hell ton of shit in their oculus client/soft and their firmware.
    Just CRAP!

    Thanks again, and good continuation to everyone!



    Unfortunately, i’m back in this subject…

    So, since i run Vorpx within SteamVR to solve my issue of my oculus rift S not hooking in its own environment, i was a bit surprised by my framerate that seems low for my configuration…

    seen this topic :
    So, i know it have been locked for good purpose of not spreading “false legends”, and i just don’t know myself, but it seems like i suffer from the same loss in framerate by hooking via steamVR and i should not use this way with an oculus i imagine, but that was the only solution i found to solve my issue…


    Tried to use the “generic VR headset” injection, and the change is huge…
    + 30FPS in Battlefront 2, that can make me surely able to play in G3D (actually in Z3D)
    and same for Monster Hunter World, if i can have all my frames, i can surely jump to G3D => +20 fps

    So, nothing was displayed in my rift S, just seen the results on my flat screen and still searching a way to inject properly in the rift s without steamVR. Have an idea?
    But maybe i’m wrong? Maybe even with the standard “oculus injection” i will loss as much frames? is it normal or just me?
    If you can clarify please…

    When my brothers wake’s up, i’m going to try on his computer to see if i can inject vorpx in normal oculus way on his computer.
    Wonder if all of this is cause of the borring story i encountered with my rift (explened in previous posts), or if it’s related to my windows.

    Also seen this :
    So i’m really interessted in this.
    Can this fix my issue?
    I mailed the Vorpx support to request a beta build of this version, waiting for an answer.



    mhhhh just tought i surely will not able to test it cause of the vorpx license key?

    Can i just register the computer of my brother with same key, then grab it back to my pc?

    If it works on his side, i will surely re-install windows on my computer, but will vorpx ask me for another license?


    So i tried to register on his PC, and not possible it seems…

    Can i have a free key/license only for this story please?


    Running vorpX in generic mode is fundamentally different since there is no second thread running that pushes the final image to the headset. In theory this second thread should ideally run at your headset refresh rate and only cause a little overhead, but in practice depending on the headset runtime and your GPU load the headset runtime may decide to throttle down to half. The Oculus runtime often does this despite enough headroom left for vorpX’s internal time warp unfortunately.

    Not really a problem though since in that case the Oculus runtime internally interpolates the missing frames instead of vorpXˋs own time warp. In other words: Your game may run at half the headset’s refresh rate, but the Oculus runtime creates the missing frames.

    BTW: Reducing the frame rate to half the headset refresh isn’t necessarily a bad thing. Interpolating from steady 45 to 90 can feel smoother than interpolating from fluctuating 60-80 to 90. That’s a bit of a matter of taste, but you can even enforce this with vorpX’s ‘Fluid Sync’ option if you want.


    Thanks for answering!

    But yeah i’m aware for this interpolation called “asynchronous spacewarp” from oculus i think.
    And i have the “Oculus TrayTool” to apply any settings i want on it.
    The best results i have with Monster Hunter is by disabling it entirely in Vorpx, and forcing it in my tool for exemples.
    At 40fps locked (Rift S is 80hz) with this thing and it does a pretty job! Was better than too variable framerate yes. And without any graphic compromise so…
    Others games like Battlefront 2 i really don’t like it for examples and disable it entirely, i prefer my 60FPS min than 40 with interpolation don’t know why…

    But for these 2 examples, i’m running in Z3D…If only i can have a hand on the extra frames i saw in “generic mode”

    So to clarify :
    If i understand well, there not should be a so huge difference between “generic mode” and other injections types you said? Just a little overhead?
    because the differences i see was not little at all.
    I’m affraid i have an issue…
    I see a jump from 60FPS mini against 90 mini in Battlefront 2 in a little test between “generic mode” and SteamVR mode. (Still Z3D. I have very fast tried G3D and can obtain 54 min instead of 34 something like that… Oh and interpollation totally disabled)

    Here is my hardware :
    -R9 3900x
    -RTX 2070 Super
    -16Gb 3000Mhz

    So did you think this is normal or did i have an issue on my side?
    I’m not saying anyone will have that kind of problems of course like you mentionned in one post in a topic i linked (“Trick to get really demanding games working in VorpX with great FPS in G3D” topic…)
    I’d really like to know if i have to continue investigating this issue, cause i’m passionate and want the best of my hardware and it tortures me ahah.
    And at the ends it’s really annoying/tiring i don’t have anymore idea to try…

    Thanks in advance!

Viewing 15 posts - 1 through 15 (of 38 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!