Cyberpunk VR Update Thread

Homepage Forums General vorpX Discussion Cyberpunk VR Update Thread

Viewing 15 posts - 436 through 450 (of 463 total)
  • Author
    Posts
  • #210295
    mr_spongeworthy
    Participant

    You have to make sure that the second number in the ALT+F FPS counter is your headset refresh rate. While that should be the case for any headset ideally, for Pimax headsets it’s pretty much mandatory.

    Just an FYI in case you want to dig into it RALF: Somewhere back at the beginning of this process; possibly your very first release or the second release of this mod, I was able to get the HMD sync on my Pimax 8K-X into a mode where then game’s FPS and (IIRC) the rate being sent to the HMD ran up and down in perfect sync *and* the game ran incredibly smoothly unless that rate dropped below something like 45 (Z3D, not AFR; that’s way to low for AFR). It worked really well. I think I posted the exact sync settings I used somewhere back in this thread(?) But then some updates occurred, whether vorpX or Cyberpunk I don’t remember now, and I believe the sync-language in the vorpX mod changed again slightly, and it’s never really worked as well for me again. For the week or two that worked I’m pretty sure I was running the HMD at 75hz and just letting the FPS run up and down between 45 and that cap at 75, and it was buttery smooth throughout. So you definitely had things *perfect* for Pimax (or, at least, for my setup) at that point.

    Here we go, my original post about the settings that worked for me, from Jan 3rd:

    “A quick tip for Pimax users (at least, my 8K-X, but I suspect other Pimax HMDs should behave the same way): In playing around I discovered that *by far* the smoothest and best performing HMD-sync parameters were: Custom: Sync = Fast, Frame Rate Limit = Yes -> Small Delay or OFF (but you’ll have to reset it every time if you choose OFF). HMD Multithreading = ON. Just the HMD Multithreading alone nets me 15fps. I’m running my HMD at 75hz in this case. I get very smooth overall performance that varies between approx. 50 and 75fps, but with zero stuttering or other issues.”

    #210296
    senrab
    Participant

    Hi Ralf,

    Thank you for trying to help me out with anti-aliasing awhile back… I will sheepishly admit aliasing was actually working and I was confusing the AFR halo artifacts for aliasing. But anyways…

    I am wondering if there is a way to avoid switching into edgepeek mode during cutscenes? I know you will probably find your head mildly disconnected from your body… but my impression from trying the (overall inferior) LR VR mod was that the immersion is still greater in spite of this if G3D is left on during those scenes. It’s sad that some of the most emotional moments in the game (like the romance scenes for example) end up feeling like a fixed, non G3D video, I can see how some people would prefer that but it’d be nice to have the option.

    #210309
    Ralf
    Keymaster

    I’ll look into that, but no promises. There aren’t many things a VR game should absolutely never do, but binding the player to a moving cutscene camera is one of them. Nothing more uncomfortable and dizzying than that, even for VR veterans. Official VR conversions of flat games like e.g. Hellblade typically handle that in the same manner as the mod.

    #210342
    senrab
    Participant

    That’s reasonable, I’m lucky enough to be immune to motion sickness/dizziness but I can appreciate how that would be a major deterrent for some people.

    #210487
    3oxis
    Participant

    I don’t know if there was a game update yesterday but the mod doesn’t go into VR. I played the day b4 yesterday in glorious VR but Steam auto-updated my game, then, I downloaded the most recent one about 20 mins ago.
    What can I do?
    Thanks in Advance

    #210488
    Ralf
    Keymaster

    Whenever a new game update gets released that the mod doesn’t cover yet, it displays a message suggesting to install the latest version of the Cyber Engine Tweaks modding framework. CET has to be be updated for each Cyberpunk release, which should usually fix the mod after a Cyberpunk update.

    The link below has detailed instructions:
    https://wiki.redmodding.org/cyber-engine-tweaks/getting-started/installing

    #210490
    3oxis
    Participant

    Thanks for the Quick response Ralf. I downloaded CET 3 times.
    No show.

    #210493
    Ralf
    Keymaster

    No problem here, just checked it. Also no other reports like this. The last game update was about 10 days ago and the VR mod has been updated the same day. Please make sure that both the mod and Cyberpunk are updated to the latest versions.

    If that does not help, check whether you maybe have another mod installed that might potentially interfere, e.g. a Reshade mod would also hook into the game and cause a conflict.

    #210495
    3oxis
    Participant

    I was able to get it to work by deleting the ENTIRE game folder and doing a fresh install. Thanks for being available Ralf!

    #210505
    3oxis
    Participant

    Ralf, I noticed that going into Photo mode crashes the game. Is this normal or?

    #210526
    Raph129
    Participant

    Hi, just notifying (I have already updated CET) Cyberpunk has been updated again, and mod does not work now (without updating CET)..
    All, update CyberEngine Tweaks or wait for update mod.

    #210543
    Ralf
    Keymaster

    @ 3oxis:

    Never tried that TBH, but I’ll take a look at it.

    @ Raph129:

    Thanks for heads-up. I uploaded a new installer with the latest CET included.

    #210654
    3oxis
    Participant

    @Ralf you okay man? Just checking on ya.

    #210655
    Ralf
    Keymaster

    Sure. Your photo mode issue is not forgotten. I didn’t have a chance to check that yet though. No promises, but if I can replicate and fix the issue, I will do so before the next update.

    #210687
    mr_spongeworthy
    Participant

    Sure. Your photo mode issue is not forgotten. I didn’t have a chance to check that yet though. No promises, but if I can replicate and fix the issue, I will do so before the next update.

    Mine does this as well; immediate crash upon entering Photo Mode. I believe it started with the first stand-alone version of your mod (i.e. I *think* I could access Photo Mode fine when we still launched Cyberpunk normally as we would any other vorpX supported title.)

Viewing 15 posts - 436 through 450 (of 463 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!