Cyberpunk VR Update Thread

Homepage Forums General vorpX Discussion Cyberpunk VR Update Thread

Viewing 15 posts - 61 through 75 (of 948 total)
  • Author
    Posts
  • #208668
    ohgrant
    Participant

    Thank you for the great Christmas present Ralf. Works pretty darn good here with the WMR patch on my G2. At first I was getting the flickering I was reading about. I found turning on v-sync fixed that for me. Very playable now with G2 when I get the controller scheme sorted.

    I’ll be playing it with the G2, but also have an Oculus. I was getting the same crash as I was getting in Oculus as I was getting on the G2. No biggie for me since now working in WMR but was thinking it would probably greatly benefit from Oculus’s ASW? Also another fan with Oculus in there forum is also getting that crash, just thought you should know. Looking forward to your next update tomorrow. Thanks again for being there Ralf

    #208674
    Demuse
    Participant

    You’re right Ralf, switching to 1920×1080 or 2560×1440 solves my inventory-screen issue. I apologize for blaming vorpX for this known Cyberpunk bug before doing enough research! I leapt to conclusions when I noticed the pop-up appeared differently in my left and right eye — I guess that means there’s at least some interaction between the game bug and vorpX.

    I think the best case for ADS is while you’re holding the aim button, you aim and move with your head, so the camera is re-coupled (De-decoupled? Undecoupled!) with the center of view. Release the aim button to decouple (de-undecouple?) the camera again.

    Is there any other trickery that can be done to the HUD other than scaling it linearly in x and y? It scales itself for different resolutions, can it be fooled into rendering for a different resolution than the game is using? Or be divided into zones that are scaled or shifted independently?

    #208675
    Ralf
    Keymaster

    Head aim ADS will be available in an update tomorrow.

    #208678
    stanley550
    Participant

    So I’ve reinstalled the game from scratch, brand new.
    Installed the VR mod.
    Unfortunately still experiencing an unbearable jitter when turning the character using either a mouse or a controller.
    Moving my own head when looking around produces a good, clean, smooth image, but as soon as I start turning the character via a mouse, the whole picture jitters and I’m seeing really bad ghosting, resulting in a very bad motion sickness.

    VorpX framerate and refresh rate of the HDMI show 50-60FPS with a solid 80 for the refresh rate, this is exactly what I have my Quest set to.

    Any help?

    Specs:
    Quest 2
    2080Ti
    i7 4790K
    32G RAM

    #208679
    mstmorse
    Participant

    Great mod! perfect timing. My 3080 just came in. I have tried it on my HP Reverb G2 but want to also use my Oculus Quest 2. Can I seemlessly switch between the two or do I have to do the setup whenever I change headsets?

    #208682
    Ralf
    Keymaster

    @ stanley:

    If the ALT-F FPS counter shows stable XX/80, there shouldn’t really be any judder when you turn with the mouse. However, if you still encounter that for some reason, you could either switch to gamepad or VR controller. All input methods are factored into the alternate eye frame interpolation, but for gamepad/controller input that works a bit better than for mouse input. The game is designed around gamepad input anyway.

    You could also try switching to Z3D in the menu. Doesn’t look as natural as Alternate Frame Geometry 3D, but on the other hand also doesn’t come with its drawbacks.

    @ mstmorse:

    You would just switch between ‘Oculus’ and ‘OpenXR’ in the little config utility when you want to switch headsets.

    #208702
    mstmorse
    Participant

    I feel like an idiot. what little config utility. I set oculus to default in the oculus app and it still says it is set to openXR but should be set to oculus for better performance. Is there anywhere else I need to make the change?

    #208703
    Ralf
    Keymaster

    The mod comes with a little config app that let’s you choose a VR runtime. The mod installer should have created a ‘Configure CyberpunkVR’ shortcut on your desktop normally.

    #208704
    Ralf
    Keymaster

    2022/01/02

    Version alpha 2 is now available for download with the following changes:

    • Aiming down sights reworked. You can now aim with your head while aiming down sights. Controller aiming is still possible too.
    • Incompatibility warning for older game versions
    • Various smaller fixes and improvements
    #208707
    drowhunter
    Participant

    Can’t wait to try head aiming. I have an issue with it though.(pre head aiming patch)

    When aiming down the sights the gun will often be on the wrong angle or too high in the view.

    It makes hitting anything impossible.

    Is there a way to have a crosshair when using Aiming dow the sights?

    Also regarding normal (non ADS) aiming . i noticed by shooting bottles on ledges. That the tiny blue crosshair is not align correctly causing shots to miss their target.

    I have aim assist off.

    Could this be related to the 16×9 hud issue you mentioned earlier?

    #208708
    drowhunter
    Participant

    OpenXR works with all of my headsets even oculus provided you set your current headset as the openXR runtime.

    Havent noticed any major drawbacks.

    Im not sure but I was changing SS settings in steamVR and it didnt seem to affect the visuals of the game. Does the Mod bypass this with its own resolution setting?

    #208709
    Ralf
    Keymaster

    Aiming down sights should work under all circumstances now.

    As far as normal aiming is concerned, I learned that shooting without ADS is much less precise in the game, which is why ADS is so important in the first place.

    SteamVR supersampling is of no relevance for vorpX. For a higher resolution use the ‘Resolution Quality’ setting in the mod options menu.

    #208710
    mstmorse
    Participant

    And now I feel like a bigger idiot. Did not see that. I was was able to get it playing on the oculus using the steam runtime with VD. Is it only playable on oculus runtime with a cable? says that can not find the headset when trying on VD using oculus runtime.

    #208711
    Ralf
    Keymaster

    VD requires SteamVR, but the mod doesn’t require VD. The best way for Oculus headsets is selecting ‘Oculus’ in the config app and then using Oculus Link (wired) or AirLink (wireless). Only use VD if for some reason you can’t make Link/AirLink work.

    #208716
    ohgrant
    Participant

    Got the new build, I was getting some extreme aliasing around some images before, I tried many settings in the Vorpx driver settings that helped like turned res up to nicest and applied AMD FSR/IFX
    in the Vorpx settings, was still just getting small improvements.

    I found forcing FXAA on and enabling and setting the image sharpening to 8.0 really makes more difference than all the other tweaking combined. For Nvidia cards I would highly recommend trying out NV’s image sharpening on this one.

Viewing 15 posts - 61 through 75 (of 948 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!