Cyberpunk VR Update Thread

Homepage Forums General vorpX Discussion Cyberpunk VR Update Thread

Viewing 15 posts - 76 through 90 (of 931 total)
  • Author
    Posts
  • #208724
    Ralf
    Keymaster

    vorpX has FSR upscale and sharpening built in. Another round of sharpening before that is possible, but probably not the best idea. Applying multiple upscale/sharpening effects on top of each other usually does more harm than good.

    Instead adjust the ‘Clarity’ setting in the mod options to your liking (Image page). Per default it does sharpening only to keep the performance impact low, setting it to ‘Medium’ fully enables the more complex FSR upscaling. The upsacle/sharpening kernels are intergrated into the image processing pipeline at the best possible points in time, so there is no better way to apply sharpening than with the Clarity option in the menu.

    #208727
    ohgrant
    Participant

    I’m pretty sure I had that set to the highest FSR upscale and the image slider all the way up and still getting the alising around all forms. I can’t rule out that a restart apply, didn’t contribute to the results I’m getting now, or the section of the game I’m in but I assure you that the image adjustment in the NV image sharpening made the biggest difference here without any noticeable hit in performance on my 1080ti 2700x machine. I’ll play more with it when I get home to be sure.

    #208728
    Ralf
    Keymaster

    Just keep in mind that when you render at a lower res, then upscale/sharpen and afterwards upscale/sharpen again, you don’t really get a better image. You not only upscale the image, you also amplify imperfections, ultimately doing more harm than good. These algorithms aren’t some kind of magic that can make a poster out of a stamp (figurativly speaking) by stacking them on top of each other multiple times.

    For a really crisper image there is no way around increasing the actual resolution. Unfortunately with your GTX1080 raising the actual game resolution beyond the ‘Nice’ default in the options menu is a tough cookie in this case though. Probably will tank the famerate into unpleasent regions.

    #208735
    mr_spongeworthy
    Participant

    After some more playing-around I was able to get 1.31 to look as good at 1.23, and was able to transition and really dig into this.

    I have to say, the results are very good most of the time. There are random times when you’ll get extremely obvious artifacts, which I now understand are due to TAA. It’s a real shame that even with direct VR we have to have these artifacts, because it’s really the only thing getting in the way at this point.

    A quick tip for Pimax users (at least, my 8K-X, but I suspect other Pimax HMDs should behave the same way): In playing around I discovered that *by far* the smoothest and best performing HMD-sync parameters were: Custom: Sync = Fast, Frame Rate Limit = Yes -> Small Delay or OFF (but you’ll have to reset it every time if you choose OFF). HMD Multithreading = ON. Just the HMD Multithreading alone nets me 15fps. I’m running my HMD at 75hz in this case. I get very smooth overall performance that varies between approx. 50 and 75fps, but with zero stuttering or other issues.

    #208751
    Ralf
    Keymaster

    Just a heads-up that the Pimax default is single threaded on purpose. This is Pimax exclusive though to deal with potential judder caused by Pimax’s ‘Brainwarp’ software layer when running multithreaded.

    For all other headsets the default is the same as ‘Favor Framerate’, i.e. multithreading is on per default. So no need to tinker with the sync settings to gain more FPS.

    #208755
    drowhunter
    Participant

    Just a heads-up that the Pimax default is single threaded on purpose. This is Pimax exclusive though to deal with potential judder caused by Pimax’s ‘Brainwarp’ software layer when running multithreaded.

    I turned brainwarp off as it was causing heavy judder. So in my case (with BW off) I guess i need to enable MT.

    #208757
    drowhunter
    Participant

    There are random times when you’ll get extremely obvious artifacts, which I now understand are due to TAA. It’s a real shame that even with direct VR we have to have these artifacts, because it’s really the only thing getting in the way at this point.

    Is there any way to force disable TAA, maybe a mod?

    #208758
    Ralf
    Keymaster

    Worth a shot for Pimax users to switch the sync from ‘Default’ to ‘Favor FPS’ and see how well that goes. That enables multithreading with Pimax headsets. For all other headsets ‘Default’ and ‘Favor FPS’ are the same.

    You can turn off TAA with the CyberEngine tweaks mod framework that the VR mod happens to use. If you didn’t have it installed prior to installing the VR mod, you can open its option menu with the page down key, otherwise with the key you assigned yourself earlier.

    The image looks extremely bad though without TAA, so you will only do that once to see how bad it looks. ;) It might be possible to work around the related glitch. I’ll check that shortly. You could also switch to Z3D, although that comes with its own artifacts. All extra benfits of the mod like 6DOF tracking, decoupled walk/look etc. also work with Z3D.

    #208763
    hafentoni
    Participant

    Is it just me or ADS switch in a 2D mode and i see a gun that is big like a tanker? And it zoom‘s way to the right from the Center i pointed initially. On a bike the Head is a bit behind the Body. But else, nice Mod.

    Will there be solutions in the future?

    Using 3080ti HP reverb G2 WMR

    #208764
    Ralf
    Keymaster

    Not quite 2D, but almost. That’s not a technical limitation or bug though, it’s done on purpose. Think about how ADS works in reality: it’s 2D either, you close one eye and aim with the other one, which of course you can still do if you want to.

    In VR however one has two options: option 1 is making ADS work like reality, so you would have to close one eye and use the other one to aim, option 2 is reducing stereo a fair bit so you can aim down sights with both eyes. Both options are 2D, the second one is much more comfortable though. It also doesn’t require any configuration, since some would otherwise prefer the left eye while others would prefer the right eye.

    #208766
    hafentoni
    Participant

    Thanks for the explanation, I could live with that. But if i aim at a Target and then ADS and i am now 20 Meters away from it and have to search it again is a gamebreaker. Sorry :)

    #208769
    Ralf
    Keymaster

    If I understand what you mean correctly, I’d consider it the other way around. Head aiming makes ADS an order of magnitude easier than it is normally in the game where you have to aim with the controller. That actually does break the game’s balancing. There should at least be some kind of challenge involved other than just looking in a direction, pressing the ADS button and shooting with near 100% precision.

    #208771
    Stryker_66
    Participant

    Just dropping in to comment on the last update on this mod. Using the mouse left to right no longer stutters and at a resolution of 2560×1440 (FOV 20) in immersive mode, things look really good and I am experiencing very little framerate stutters. Really great work on this mod, this game is a real blast and I am enjoying it immensely in this format. Glad I waited until a mod like this to have a first play through. Thanks again and happy 2022!

    #208773
    mr_spongeworthy
    Participant

    Re: Disabling TAA.

    I’ve found that using CET to disable it does not always work. You can google for instructions for disabling it by creating a new .ini file containing specific lines. Like RALF says; there is no other form of AA available in Cyberpunk, so it looks pretty awful. DLSS also won’t work, so you are probably looking at 1080p resolution to get the frame-rates needed for VR. As bad as TAA is, there currently isn’t anything you can do except use it in this title. In pancake mode you might be able to use ReShade to add AA, but again, can’t do that in this case as Cyberpunk will CTD with vorpX + ReShade.

    #208777
    Ralf
    Keymaster

    @ Stryker:

    Thanks, a happy 2022 to you too!

    @ mr_spongeworthy:

    DLSS works perfectly well, if you really want to use it, that is. I‘d advise against that though in the majority of cases. It‘s useful at slightly below 4K resolutions to fake 4K, but at medium resolutions in a VR headset it‘s just too blatantly obvious that DLSS upscales to the target res from a way lower render res, AI or not. Clearly subjective, but except for the situation described below I wholeheartedly recommend to go without raytracing/DLSS. The crisper image without DLSS just is the bigger overall benefit, no matter how great raytraced lighting here and there may look in the game.

    The only setup where I found DLSS (at ‘Balanced’) worthwhile is with a highend GPU (read RTX 3080+) and the ‚Resolution Quality‘ cranked up to max. No raytracing though. While performing similarly that looks fairly spectacular and actually better than ‚Resolution Quality‘ two or three notches below max without DLSS. If a stable framerate isn’t paramount for you (it should), with such a setup you may even experiment with raytracing.

Viewing 15 posts - 76 through 90 (of 931 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!