Forum Replies Created

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • in reply to: Final Fantasy XIV #211067

    Finally figured it out !!!

    If, like me, you are NOT using steam to launch FFXIV, add FFXIV launcher to Steam (Games -> Add Non-steam games to my library).

    Make sure your controller is recognized by Steam.

    Once that is done, start VorpX. In the configuration menu, deactivate “Try to block known games overlay”. The controller should now work in game.
    In game, open the VorpX menu and deactivate the oculus touch and the gamepad override options to ensure nothing interacts/messes with the controller or the mouse

    But WAIT, we can push it further!

    If you have AutoHotKey, copy this script to a .ahk file
    f1::Click Down Right ;Press F1 to hold the right mouse button down
    f2::Click Up Right ;F2 to release the right mouse button

    Start the script, and once in VorpX, go fullVR (G3D) and activates FFXIV’s first person view (press R3 on PS controller or Home button on keyboard I think). Press F1 and it’ll do the same as maintaining right click down, allowing you to move the camera with your head.

    This pretty much renders your mouse unusable, but if you play with a controller, that should be irrelevant. The game has a surprisingly vast amount of options that can be keybound.

    Adjust FOV to your liking (I found that reducing it to minimum provided the best experience for me)

    BUT WAIT, there is more!

    We can also install GShade to make the game even prettier!

    When installing GShade, make sure to select Alternative DirectX Mode (d3d*.dll) and not “Normal Mode”. The default normal mode will use dxgi.dll to inject itself, overriding your FFXIV-vorpx hook and making you unable to use both at the same time. This method bypasses that issue.

    Find some good gshade preset you like and voila!

    in reply to: Final Fantasy XIV #211063

    This is getting more and more confusing.

    I found this video of someone actually managing to do that, using both controller and keyboard/mouse combo (video with timestamp)

    Clearly it IS possible, somehow, but I’m out of ideas T_T

    in reply to: Final Fantasy XIV #211042

    I don’t mean to spam but I can’t seem to edit my own post :/

    So I did some research and found out that sadly, many games don’t allow simultaneous mouse and gamepad input. So whenever vorpX needs to emulate a mouse for headtracking in an affected game, the gamepad mapper is used to resolve this conflict.
    I believe it is the case for FFXIV as the game does come with a built-in toggle in the menu to swap between gamepad and kb/mouse.

    I’m not sure about how this works exactly as you can still use your mouse/kb in Gamepad mode for stuff like turning the camera or chatting with people, maybe @Ralf can have some input here, but I believe that this is the core of the issue and that there might not be any solution for it.

    The only way I found to make this work would be to use keyboard and mouse only, but considering that the script requires right click to be on at all times for the camera head tracking to work, you would need to play with keyboard only and nothing else, which surprisingly, actually works, but is obviously not the most convenient experience to have.

    A shame, I felt like I was so close :/

    in reply to: Final Fantasy XIV #211036

    The script works but the moment I start VorpX with my controller connected, the controller doesn’t work?

    Somehow the game recognizes it’s there but all it does is emulate my mouse, I can’t use it as an effective controller.
    The controller works again the moment I deactivate vorpx

    in reply to: Final Fantasy XIV #211035

    Agreed! The video I was referencing is here: They mention that they’re using VorpX, though I guess I’m not entirely sure if it’s with @dellrifter22 ‘s profile or not.

    Scrap that, I found an “inconvenient” workaround, I think?

    When you go into first person mode and use right click, the head tracking work in G3D as long as you stay pressed on right click the entire time, meaning if you wanted to play with head tracking on in first person, you’d need your right click to be on at all times.

    Now something that -might- work and that I’ll have to try tomorrow would be to do just that by playing in controller mode and running a script that would basically maintain my right click on the entire time.

    I wish there was an easier way of doing this but I’ll have to see if that method works in itself. I tried it with the keyboard + mouse for a few minutes earlier, just walking around in Limsa Lominsa in first person with head tracking and it was AMAZING.

    in reply to: Final Fantasy XIV #211033

    Ah, is that supposed to be the in-game first person toggle? I was able to get that working. Is there an easy way to get VorpX to stick onto my character’s head? I’ve seen a YouTube video of someone using your profile actually looking around in first person using VorpX, but I can’t get mine to look any better than the floating screen mode.

    I would very much like to be able to do that as well.
    I can confirm that Home is the first person mode for FFXIV, but then when I right click to try and turn the camera around, it doesn’t seem to work at all here.

    I wish there was a way to make the camera follow your character’s line of sight so you could look around like if you were truly in game. Honestly after having tried dellrifter22’s G3D profile I was amazed by how beautiful the game looked and I’m pretty sure if the head tracking could work, we would have the next Sword Art Online right here xD

    in reply to: Final Fantasy XIV #206779

    I have a follow-up question now.

    I used the method explained above and I managed to get it to work!
    I can hook VorpX to FFXIV and play in cinema mode without problem.

    However I was wondering how you guys managed to make it work in Full VR.
    When I try to switch to FullVR, it “feels” first person, but when I move my head, it’s like what I see on screen just follows and keep being recentered in front of my eyes rather than if the camera was looking around (if that makes sense?)

    Have you guys found a workaround to make the camera follow your head movements?

    in reply to: Final Fantasy XIV #206570

    Oh nice, thanks for the tip!
    So headtracking and everything?

    Frankly the idea of playing a MMO while being fully immersed in it is just blowing my mind. Can’t wait for next week to try it out as well!

    Aslo thanks for the reupload of the file :D

    in reply to: Final Fantasy XIV #206479

    could I ask for a reupload of the file?

    Also, has anyone else had any luck with the G3D mode for this game?
    I am half tempted to get back to FFXIV but I think I’m probably only gonna do it if it actually works so I’d like to know if this has also worked for everyone else who has tried the above mentioned trick :)

    Thanks again for all your work on the testing!!!

    in reply to: Second screen zoomed in? #197607

    Haven’t found a way to edit my post.

    After some fiddling, it seems the “zoomed” screen is actually centered on my mouse :/

    in reply to: Image follows eye movements #197461

    I haven’t played Arma 3 but I fixed a similar problem in Dragon Age Inquisition.

    In DAI, the issue came from the fact that camera movement was actually bound to a key. In the normal game, you don’t move the camera by simply moving the mouse, you need to hold right-click while you do it. While using a first person mod with VorpX, not using the mouse caused the camera to simply follow my head movements and stay centered in front of my eyes at all times.

    Turns out it was a simple toggle that I just had to deactivate in the settings to fix it.

    You should check your settings and key bindings to see if the camera is linked to a similar key.

    Hope it works!

Viewing 11 posts - 1 through 11 (of 11 total)

Spread the word. Share this post!