Cyberpunk VR Update Thread

Homepage Forums General vorpX Discussion Cyberpunk VR Update Thread

Viewing 15 posts - 211 through 225 (of 930 total)
  • Author
    Posts
  • #209524
    RobCram
    Participant

    I just made a video. Gestures work really great although need to map some of the controller buttons and tune the steering sensitivity. Just need the actual character hands in VR. Thanks Ralf, great work!

    #209525
    Ralf
    Keymaster

    @ luris:

    You’re welcome.

    @ RobCram

    Thanks for the video. Curious what you had to remap. You shouldn’t have to, but maybe I overlooked something.

    Just in case: motion controllers should be left at ‘Gamepad’ mode in the vorpX menu, which is essential for smooth steering. Changing the motion controllers to keyboard mouse makes steering just as awful as steering with an actual keyboard. With motion controllers in gamepad mode and the game’s gamepad bindings at default everything should just work.

    #209526
    RobCram
    Participant

    @ralf yeh the HP Reverb G2 buttons (A/B/X/Y), none of them work at all. Could this be because I have a gamepad connected at the same time?

    #209527
    Ralf
    Keymaster

    That’s weird. Works for me. The controller type should either be ‘Auto’ or ‘Oculus Touch’ for Reverb G2, not ‘Windows Mixed Reality’. That’s somewhat confusing admittedly, guess I should find a better solution for that. The ‘WMR’ controller type is for WMR gen 1 controllers. The Reverb G2 controllers are more or less Oculus Touch replicas and work just fine as such.

    Whether an actual gamepad is connected shouldn’t make a difference. Provided you have four hands you should even be able to use both at the same time. ;)

    #209529
    RobCram
    Participant

    Ahh, that is probably it because I changed that setting to WMR.

    #209530
    Demuse
    Participant

    My Reverb G2 controllers work, set to “Oculus Touch”.

    Upon startup, the tutorial is displayed front-and-center, while the game menu screen is visible off to the left. Pressing a button to exit the tutorial also has the effect of selecting “continue” from the main menu. Can that be changed so the button exits the tutorial and brings up the main menu?

    #209531
    Ralf
    Keymaster

    Do you have some mod installed that removes the game’s intro screen? Normally there should be a screen before the menu that requires you to press the menu button to get to the main menu.

    Either way I’ll check wether I can easily add a little delay until game input gets enabled when leaving the start environment. No promises, but unless I have to spend a whole day for it, that’s actually a good idea anyway.

    #209533
    mstmorse
    Participant

    Using Quest 2 and downloaded the most recent download. Not getting the tutorial on gestures. Do I have to start a new game to see them. I have the settings as gamepad.

    #209534
    Ralf
    Keymaster

    Controllers have to be enabled when launching the game for the gesture tutorial to show up. If that doesn’t work for some reason, try to go back to the start room later from the vorpX menu. Maybe your controllers aren’t detected correctly directly on launch. With some luck they are shortly after.

    Would be great if you could let me know whether that helps or not.

    If the game doesn’t even launch in a room where you see a tutorial screen in front of you, the install failed. In that case please try to uninstall/reinstall.

    #209535
    mstmorse
    Participant

    Just tried it on oculus quest2 on virtual desktop, and also airlink. Both using the steam profile. also HP reverb g2 and same thing. no gesture tutorial. When I pull out a gun, and this may be something with the game becasue I am right at the beginning, they wont even aim and just point 45 degrees to the left. Used the Cyperpunk configuration between each use. Allows me to push the button commands but no gestures. Should I delete the mod totally in add/remove programs and reinstall? This time I installed over the old one.

    #209536
    mstmorse
    Participant

    OK, so I deleted the mod and installed. Tutorial now shows up. sweet! But the guns still point 45 to the left the gestures are not working, like swinging the baton when in the game. I will keep playing around and seeing what is up. Prob start a new game and drop settings. alt-F shows 102.

    #209550
    Ralf
    Keymaster

    Sounds as if tracking isn’t centered. That should happen during the start normally, but you can repeat it any time from the vorpX menu. There is a recenter button on the main page of the menu.

    If you play standing, play standing in place. Always keep your body front facing after tracking has been centered, use the right controller thumbstick to change your character’s direction. Do not turn your body to change direction in the game, that doesn’t work since head rotation is realistically decoupled from body rotation. I.e. your ingame character can walk in one direction while you look into another.

    #209551
    drowhunter
    Participant

    when aiming down sights using gesture. I notice that the zoom in happens but movement can only be done right stick and not by your hands.

    Also right stick can only move view horizontally when in ADS which makes it even harder to hit a target.

    One other thing. Using index controllers the amount of force required on the grip to enter shift mode is too hard.

    Would it be possible to make thr force required adjustsble under input?

    Even better once toggled if could stay toggled until you completely remove your fingers from the grip this way I dont need to do a death grip on my left hand whilst also tryimg to use the dpad or buttons on the left.

    #209552
    Ralf
    Keymaster

    You can aim with your head in ADS mode since a while. Thumbstick only ADS like in the first version was a necessity caused by how the mod does decoupled walk/look and I originally liked it actually, but in terms of playability it wasn’t that great. Worked fine for a more stealth oriented play style, but not really good for anyone prefering fast paced run and gun gameplay. So since a while you can head aim in ADS mode and with the latest release that also works seamlessly when you switch to ADS while looking into a different direction than you walk in.

    Too little force for map shift also isn’t good. In more hectic situations that often leads to triggering map shift inadvertantly. I almost spent a full day with finding a sweetspot when I added Index controller support two years ago or so.

    The other idea sounds great though! Requiring a higher force only initially might be the perfect solution to inadvertantly triggering map shift without requiring that ‘death grip’ all the time. I’ll definitely check that.

    #209553
    Ralf
    Keymaster

    OK, this little change improves Index controller handling enough to warrent a hotfix. I didn’t change the version number, but when you redownload and reinstall, you’ll get an updated version despite it showing the same version number as before. You still need the same amount of pressure to enable map shift initially, but only 5% to keep it enabled afterwards.

    @ demuse:

    This hotfix also comes with the little delay before game input gets enabled after leaving the start room, which at least in theory should help with your continue issue while the game’s intro sequence is disabled. I didn’t actually check that, but it should do the trick, I think.

Viewing 15 posts - 211 through 225 (of 930 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!