Cyberpunk VR Update Thread

Homepage Forums General vorpX Discussion Cyberpunk VR Update Thread

Viewing 15 posts - 556 through 570 (of 946 total)
  • Author
    Posts
  • #213536
    mr_spongeworthy
    Participant

    @Ralf – my issue may be limited to that specific location or at least a subset of locations. I have been running around elsewhere and not seeing the same problems. It’s still very odd though, so if you have a moment to look, just for kicks…


    @AtomicWalrus
    – It would be interesting to see how AFR works in a title that does not have forced TAA. I *think* AFR is largely analogous to the old “frame packing” 3D methods we used with shutter glasses, and that never produced issues like we see with AFR on our HMDs. I *think* a lot of the problems stem from TAA, but that’s hard to defeat in Cyberpunk for testing (defeating TAA causes other issues.) Maybe Ralf could add an AFR mode to other titles eventually, and we might know more then.

    #213675
    drowhunter
    Participant

    Does this still work with patch 1.61 that dropped today?

    #213678
    Psyclops
    Participant

    It seems to only sort of work. It does not want to go into Full VR easily, and the head tracking works incorrectly.

    #213684
    Ralf
    Keymaster

    Doesn’t work currently. The latest version of the Cyber Engine Tweaks modding framework comes with changes that break the communication between the C++ and the game script portion of the mod. I have to figure out something new in that respect. Might take a few days.

    #213692
    Ralf
    Keymaster

    2022/11/10

    Version alpha 8 is now available. This update adds compatibility with Cyberpunk 2077 1.61.

    Faster than expected, luckily everything required for a new C++/game scripting communication method was already largely in place on the vorpX side, so the hardest part was figuring out what caused the issue and coming up with an idea to deal with it.

    Latest version available here:
    Download

    #213697
    moarveer
    Participant

    Fantastic news, thanks Ralf for the fast update.

    #213745
    Thavex
    Participant

    @Ralf doesn’t seem to be working at least with my Oculus Quest 1 through Steam, gives me a D3D12 doesn’t work with oculus message everything else just CTD trying to use SteamVR. Trying to use the regular paid VorpX app does the same CTD. Dunno whats going on. Screenshot enclosed: Oculus error https://imgur.com/a/obd8BJa , Using SteamVR mode from config results in flatline https://imgur.com/a/aci1b9f

    #213751
    Ralf
    Keymaster

    No such problem here, Quest (2) is the main dev platform since quite a while. Also no other reports like this, so it’s fairly safe to assume that this is some conflict specific to your config. Judging from the symptoms you describe probably something getting in the way that also hooks into games. If you have any other mods installed, try without. Also disable/remove any tools/utilities you may have running in the background. A lot of tools hook into games these days.

    #213752
    Thavex
    Participant

    Your right reshade strikes again. Removed it and its working fine now. Except for one annoying thing any way to fix the really sickening jutter from looking down? I’m fine looking up but looking down makes the image shake like crazy.

    #213758
    matteo39
    Participant

    i play in z-normal, and when amd dlss 2.1 is active, there is a strange effect on screen, on the top of the screen, is all pixellated…

    with nvidia dlss is all ok….

    #213775
    Ralf
    Keymaster

    @ Thavex:

    Sounds as if the alternate frame 3d method (meaning that the left eye is rendered at frame 1, the right eye at frame 2 and so on) is not for you. For some (many) people that is too uncomfortable in motion since the brain doesn’t expect timing differences between both eyes. The mod tricks aways some of the issues introduced by that, but not everything can be tricked away.

    You can switch to Z3D in the mod menu instead. Doesn’t look as natural as the default method does, but on the other hand doesn’t come with confusing timing related glitches.

    @ matteo:

    Thanks for the heads-up. Stick to nVidia DLSS then please. I’ll check whether it’s possible to also make the AMD method work with Z3D, but no promises.

    #213784
    mr_spongeworthy
    Participant

    A bit of feedback from me after updating to a 4090. I’ll put some other results in a different thread:

    The stand-alone vorpX CyberpunkVR mod absolutely refuses to push my GPU when I am sending to my Pimax 8K-X. CPU usage is fine; I’m not being CPU limited as far as I can tell. All is good when I’m pushing with main version of vorpX to my 3D display instead of my HMD. (I have yet to update my profile database – so I don’t think I have the latest profile for Cyberpunk however. I’ll try to find time to test that soon.)

    It does do a very smooth job of things in “Judder Protect” mode, but FPS is pretty low as I’m peaking at about 60% GPU usage. The result is that my performance uplift over my 3080ti is not as great as it should be. A number of settings also refuse to stick and/or seem to be ignored. It reverts to AFR each time for example. The GUI reads Z-Normal, but it isn’t actually using that. I have to flip it back and forth once and then it is fine. Not a big deal. The motion smoothing is also sticking “ON” even when I try to turn it off.

    At this point this looks to be specific to the full MOD. Everything I run through regular vorpX got a considerable performance uplift, and Cyberpunk itself got a considerable uplift except when running through your mod. Native VR games also got the expected uplift (mostly.)

    P.S. If you add an above/below mode to your 3D Display support, instead of just SBS, I will buy you a pint of Old Peculiar.

    #213787
    Ralf
    Keymaster

    Judder protect uses hard CPU/GPU syncing and is thus *really* slow, also almost certainly CPU limited in most situations. Don‘t use unless necessary. Pimax headsets are a bit iffy, but even with a Pimax that shouldn‘t be necessary usually.

    #213795
    mr_spongeworthy
    Participant

    Thank you! That was indeed the issue. It’s a bit more complicated, but switching to Fast + the Multi-thread option resolved the problem. Currently I’m at 75hz at 1/2 Sync, 4K with RT (ultra) and It’s just about rock-solid. Also trying it with the PiTool Motion Smoothing (so vorpX smoothing off) and that also appears to be working, for now. (There are *huge* issues with Pimax smart-smoothing currently. They tried to implement a 1/3 rate, but provided no means to turn that rate off. So you can’t limit it to 1/2 rate. Instead it will auto-switch to 1/3 and back whenever it wishes to do so, which is often when it is unnecessary. It’s entirely over-aggressive when determining when to use the 1/3 rate. Also, the Pimax 1/3 rate is absolutely awful, making the entire Smart Smoothing “feature” useless most of the time. No idea why it actually seems to be working Cyberpunk+vorpX, but only more testing will tell for sure if it’s reliable or not.)

    Ultimately, at 90hz + 1/2 rate the only thing that got rid of microstuttering was the Judder protect mode, even though looking at the performance metrics I should have been fine. I’ll have to give it a try again later once the 4090 drivers are a bit more mature.

    #213815
    Ralf
    Keymaster

    Would indeed be better if the headset vendors would make their auto fps-reduction configurable, at least for developers. In case of vorpX’s multi threaded rendering these things get in the way more often than they do anything useful…

Viewing 15 posts - 556 through 570 (of 946 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!