Cyberpunk VR Update Thread

Homepage Forums General vorpX Discussion Cyberpunk VR Update Thread

Viewing 15 posts - 271 through 285 (of 930 total)
  • Author
    Posts
  • #209677
    Ralf
    Keymaster

    22/02/17 Version alpha 6 is now available

    This is the “official” build for Cyberpunk 1.5. Aside from the 1.5 mod compatibilty it also contains a variety of smaller (mostly gesture related) fixes and improvements based on reports and suggestions that came in over the last days.

    Download

    #209679
    VRified Games
    Participant

    Got it working yeeeaaahhhh

    Using mobile data to download and transfer into PC worked, thank you

    Overall it’s a great mod

    Some things though

    Could the fov be tweaked when aiming

    The guns seem massive…..its a nitpick though if I’m honest….they handle so well with the gesture controls

    The interact gesture is very hit and miss for me

    I can only trigger it sometimes

    But….what if the melee gestures could be mapped to interact with the left controller?

    Punch = reach
    Swing = swipe/grab

    So left hand for interact right hand for melee?

    Also, the motorbike

    Can the controller bindings change when the handle bar gesture is activated?

    So the trigger can become the break?

    Also if you could map the analog trigger to the rotation/roll of the right controller you could have a pretty cool bike accelorator

    All little suggestions/nitpicks….but Ralf….my God….this mod is awesome

    If you could put the gestures into GTA V and red dead…..you would be blowing Luke Ross right out of the water 😂

    #209680
    Ralf
    Keymaster

    Not sure if that’s what you had in mind, but you can change the entire controller setup (button mappings as well as gestures) to left handed in the settings menu.

    Changing the aim FOV doesn’t really make sense gameplay wise. I thought long and hard about that. The whole point of scoped weapons, which are immensely important in the game, is zooming the view in. Overriding that would make scopes useless.

    The use gesture got a little overhaul today, was actually buggy. Try again with version alpha6 released earlier today. Make sure to flip the wrist inwards fairly fast and far enough. It’s super easy once you got the knack of it.

    Refined bike controls are on my nice-to-have-list. We’ll see. Didn’t want to add too much stuff that potentially needs explanation.

    GTA V gesture support is already largely done and will definitely be in the next vorpX update. RDR 2 is also on the list, although I’m not entirely sure yet how to tackle horse riding in a believable manner.

    #209681
    VRified Games
    Participant

    Great news:-D

    Horse riding….might I suggest

    If you are familier with “natural locomotion” on steam

    They have a Skyrim VR profile and how they handled horse riding is great

    You hold your controllers aloft as if you were holding the reigns

    Then move them at the same time up and down to acelerate

    Just like cowboy style horseriding

    For steering it’s a lot like your moterbike system push the left forward and right backward to turn right and vice versa

    #209682
    Demuse
    Participant

    I prefer less weapon zoom too, so I put low-power reflex sights on all my guns (except my sniper rifle). It’s cool that different scopes result in different weapon FOV, so you can customize each weapon as you like.

    It’d be even better if the total range was wider, so iron sights or certain reflex type sights had no zoom at all, for better peripheral vision and situational awareness, or for people who prefer no visual distortion or giant weapons. Then high zoom scopes are available if preferred.

    (But I still crash out about half the time when exiting the in-game menu, makes it really hard to play! Selfishly, I hope other people have this problem too, so it gets escalated and maybe someone finds the root cause or at least a workaround. It seems to depend on location: when I load a saved game in my apartment then change my loadout it crashes every time, but if I open the same save then walk some distance away and try again then it doesn’t crash.)

    #209684
    Ralf
    Keymaster

    Can’t replicate that here for the life of me. Neither the mod-script nor the vorpX internal game handling do anything special when exiting the inventory/menu except turning EdgePeek off and that hasn’t changed since the very first release. Also I can’t even imagine how that could potentially crash the game. I’ll check again tomorrow.

    Are you 100% sure that the issue only occurs with the mod? Might make sense to try a few more times without. Maybe it was just coincidence that in your prior tests it only happened while the mod was loaded.

    #209686
    drowhunter
    Participant

    The Index grip release sensitivity essentially is already ‘no force’ now. Actually 5% to account for potential sensor problems, but that doesn’t really make a difference. Thanks again for the idea.

    So I figured out how to customize the grip to my liking.

    In SteamVR controller bindings, the grip is set to
    pressure/laxisgrip.

    Changing it to “use as grab”/laxisgrip allows me to tweak grip and release pressure by clicking on the little cog in the bottom right corner.

    Sliding to the right sets the squeeze pressure
    Sliding to the left sets the distance(proximity) the fingers have to be away from the grip.

    I set the
    “Grab Threshhold” = 75 (slider to the right)
    “Release Threshold” = proximity 15 (slider to the left)

    what this allows me is a purposeful but not crazy grip to initiate the shift, but the shif does NOT release unless I remove my fingers from the grip a little bit.

    Now I can shift and press buttons at the same time like a champ.

    I’m going to experiment with having the shift act as a toggle which might actually be even better.

    By the way , the issue I was having with the ADS gesture not aiming with the hands is fixed. It was crucial to make sure the window was in focus.

    That being said the game seems to run in a little window and sometimes the mouse will leave the window causing the aiming not to work again. I think if I set the game to run fullscreen might help, but i have dual monitors so it may still happen.

    #209687
    Ralf
    Keymaster

    Not exactly sure what that does (or whether it does anything at all since vorpX loads its own SteamVR input profiles), but the values vorpX uses internally are 75%/5% of what SteamVR reports as grip sensor force, i.e. incidentally the same amount for activation and even less for deactivation.

    There is a flag I can set to lock the cursor to the window if necessary. I was under the impression the game does that by itself. Some do, others don’t. I’ll check again whether that flag is required before the next update.

    #209695
    kia75
    Participant

    When I try to download the latest version I get a File Not Found error.

    edit: Don’t know what happened, I just tried again and it downloaded. It seems to be working now, but 5 minutes ago it wasn’t.

    #209696
    Ralf
    Keymaster

    @ Demuse

    Just did another round of testing. Fast traveling from V’s appartment to half a dozen locations around the city and each time back to the apartment afterwards. After each fast travel I changed weapons and gear in the inventory, openend other menu screens and did occasional panic clicking in and out of the menu 10 times or so within a few seconds. With gamepad, motion controllers and mouse/kb to rule out an input related issue. No crash, so I’m really at a loss concerning your issue. As far as I can tell, it’s not related to the VR mod.

    @ drowhunter

    I uploded another build (no version change) that locks the cursor to the game window. Didn’t really check whether that’s necessary, but just in case. Can’t hurt.

    @ kia:

    You probably just got unlucky and tried in exact the same moment when I uploaded the new build.

    #209698
    Demuse
    Participant

    Ralf, thanks so much for your testing, I really appreciate your concern and effort! At my end, I did a clean re-install (detailed below), and confirmed I still crash. I totally understand that you can’t fix a bug you can’t reproduce, and mine crashes so often under this specific circumstance that there must be a problem at my end or everyone would be complaining. I’ll keep messing around and try to find the pattern.

    I uninstalled the game and deleted every related folder (under /users//Appdata/, etc) to remove any trace of old mods. Then I reinstalled the game, and re-downloaded just the latest versions of CET and CyberpunkVR. With CET installed (intro movies disabled) I loaded up a save and ran around for 10 minutes, swapping my outfit several times with no crash. Then I added CyberpunkVR and ran it for the first time with default settings and it seemed good with no crashes in 10 minutes. Then I tweaked a few settings and restarted the game, opened the same save, swapped my outfit once and crashed immediately upon exiting the menu. Then I uninstalled CyberpunkVR and tried again (no other changes), and no crashes in 10 more minutes.

    Observations that I’ll probe into: it seems related specifically to changing outfits. I can usually open and exit the game menu or map over and over without crashing, but when I go into Inventory and swap one piece of clothing, it usually crashes (but not always). And I feel like it’s related to graphics settings somehow, since the very first time I install the mod and leave all the default settings, I never crash, but as soon as I change the settings to my liking and restart, then I crash right away. Finally, I read online someone complaining that their framerate always drops for a while after exiting the inventory; they guessed “a memory leak?” — might be related to my problem. And I’ll try starting a new character in case it’s related to my existing saves somehow.

    #209701
    Ralf
    Keymaster

    If it still occurs with a fresh game, let me know. I guess then it’s time for an even closer look. Would be *really* weird if in some way the mod could trigger an inventory crash that only occurs with certain graphics settings.

    #209728
    xt4k
    Participant

    It seems like going into edgepeek before accessing the menu reduces the crashes, but it’s hard to predict. It’s crashing here pretty regularly upon exiting the menu… it seemed to maybe coincide with the auto-edgepeek toggle?

    #209730
    Ralf
    Keymaster

    That was my first guess too when Demuse posted his issue originally, but I have done that several hundred times since then without a single crash. Also apparently this seems to have started with patch 1.5, I don’t recall any reports like this before. Auto-EdgePeek handling hasn’t changed at all since the original release.

    If it’s indeed related to some settings, it might be worth a try to reinstall the mod and afterwards not change anything in the mod settings aside from potentially the resolution. There is no need to tinker with settings normally anyway.

    Graphics settings wise I have mine at medium. So that should definitely work. Alternatively medium + DLSS auto (no raytracing).

    If you had other mods installed before, please also try whether the issue occurs when you start a new game with only the VR mod and no other mods.

    #209731
    Zel1984
    Participant

    Just installed the updated mod for the latest version of CP2077 & now i can’t get proper VR working, it just goes into the big flat screen in front of my face, no head tracking either, pressing edgepeek button does nothing, using Oculus Rift S, anyone know how to get it working properly?

Viewing 15 posts - 271 through 285 (of 930 total)
  • You must be logged in to reply to this topic.

Spread the word. Share this post!